" Failed to execute rpc_request" error when executing sequence

Hi Guys, Having an issue with my sequence execution.

Error:

Im getting an error at the same exact time whenever i try to execute one of my sequences. the sequence im working on has 2 “execute sequence” commands and one “IF Statement” command

picture below:

The error comes at the end of my Plant seed (loop-able/chain-able) (success) <---- not so much a success at the moment, lol.

Right at the last “import Coordinates From

There is another thread here in which @whitecaps posted that he was experiencing the same thing.


In the end my goal is to be able to have this sequence go and “pick up seeder tool”, move over to the seed tray, grab a seed, plant seed at imported coordinates of my “basil” plant in the Farm Designer and then repeat “plant seed” sequence until all the basil plant coordinates from the Farm Designer have been planted then execute “put tool away” sequence.

Hope I’ve provided enough information!

-CMJ

Hey @Cjaramillogrows

Are you able to start the sequences manually?
“Could not find sequence by ID:2898” indicates that something went wrong saving or syncing. I assume you tried restarting/syncing already.

Maybe this is caused by your try to Loop the same sequence two times in one sequence. I don’t understand your sequences or your try to loop yet but i didnt look into that too much :frowning:

Thanks for the reply @Ascend!

I restarted the FB yesterday with zero results.

Going to try and flash the SD Card again and restart her. I did notice that yesterday i had to hit the sync button 2 times to get it to finally sync. the first time i’d hit the sync button it would say syncing an then change back to sync now - hopefully my sequence will work more appropriately today after that!

I also thought about the possibility of the looping causing an issue. I remember a few months back someone asked if you could daisy chain sequences together and i think it was Rory who said not at the moment. Not sure if that’s still current but I’m trying to streamline a full plant seed sequence by daisy chaining individual sequences to make the sequence itself more lean.

To simplify what I’m wanting to do - We’ve got a event coming up where were gonna have a booth at a convention and iI want to make a sequence for the FB like the intro video on Farmbot.io where the FB going through a full garden bed planting and watering.

Thanks,

-CMJ

Sounds great, keep us updated about your results in chaining sequences. I didn’t try that so far because I never had to plant the whole garden bed at once :smiley:.

1 Like

will do! :smile: hanks again for the reply.

Actually. @Ascend.

got any knowledge or heard of an issue where FB wont launch its network on its own after a restart of being turned off and turned back on?
Ive gotta flash the OS every time the FB shuts down so that it can launch its wifi. Its been a pain in the butt!

Well both, i’ve seen posts about it and i’ve also experienced this issue a few times already. Sadly I can’t tell whats happening or if there is any kind of fix for that. Sometimes it worked after one or a few restarts (unplug). Since farmbot seems to work really stable I never had to reflash again (months ago).

I assume you mean that FB doesn’t create the configurator wifi after flashing, set back to factory setting, or when he lost wifi connection and does not reconnect/open up wifi itself.

1 Like

OK gotcha, and yes its not creating the wifi config.

It’s weird. it isn’t very consistent either. FB just launched the config 3 times in a row while i was trying to connect to an access point we have and on the third time is when it went down completely and now I’m going to have to flash the SD.

I haven’t tried a factory reset yet. That may be on option as the issue could be within some settings in the Pi/Arduino but right-o thanks for the bit o’ info!

I’m afraid that looping won’t work at the moment … Maybe you found a system that I couldn’t think of, but there are a few things that I can’t find solutions for:

  • Importing the right coordinates for each seed. -> You would need predefined coordinates in own sequences, even with coordinates that are given by the farm designer.
  • What is the condition to end the loop? -> You would need to verify if the last seed is placed or the bot is at the last coordinates. Maybe even a counter, how many times the sequence has been looped would work …

Hopefully you got a great idea that would make it work. Still I’m curious :confused:

1 Like

Hmmm. :thinking:

As far as the end loop condition. My only guess was to use the IF statement to make sure the last seed coordinates have been planted - I was thinking about having the FarmBot plant the last seed - check the IF statement and IF = true( that the FB is at the coords of the last plant needed to be planted) then FB would execute the put tool away sequence. (But i feel like this has got to have been tried already with no results)

just for clarity, you said, [quote=“Ascend, post:10, topic:2589”]

  • Importing the right coordinates for each seed. -> You would need predefined coordinates in own sequences, even with coordinates that are given by the farm designer.
    [/quote]

so does that mean id have to set up a “move absolute” for each plant for accurate positioning, even thou I could just import the coords from Farm designer?

Well, if you repeat the same sequence, how would you Update the coordinates that the Farmbot should plant to?

Afaik importing coordinates means that you can select one in the dropbar of a step in a sequence like “Absolute movement”.
In your case you would need to update the coordinates automatically when the sequence finished the first time.

Ich think the only way is to use a move command for each plant with the coordinates filled in.

Ok, so here is what i have set up.


Over all Chained sequences

Start: very simple grab seeder tool sequence. Then from there it will go into the Plant basil 1 sequence.


Plant basil 1 sequence:

With the last “import coords from” command, I’m making sure the end of this sequence puts the tool head above the seed bin ( with seeder tool still attached) so that when executing the next plant seed sequence its already above the seed bin location and all it needs to do is dip into seed bin - vacuum pump on - then move to plant location coordinates and plant.


Then the sequence is going to execute a copy of the same sequence i just posted ( see picture for plant basil 1) but with the plant coordinates updated to the next location where the seed will be planted. So the only difference with plant basil 1 and 2 is a coordinate change to reflect the next location needed to plant a seed.


Plant Basil 1 seed location

Plant Basil 2 seed location


At this point i was thinking i could just copy the plant basil sequence for as many basil plants as i want to plant.

So for example i wanted to plant 5 basil seeds - once the 5th basil seed as been planted i would use an IF statement command to confirm the location for the last seed. if the statement is true, then the farmbot will execute the put seeder tool away command at the bottom of my chained sequence. if the IF statement is not true then ill have it send me an email for example.

Ive actually gotten 2 successful executions of my chained sequence but unfortunately I’m still encountering the error this thread was started on. So i don’t know how many plant basil sequences in can chain until the FB just cant handle it.

Thanks for providing the sequences. Those should work fine.

I would try to test each sequence in the main sequence (plant seed - Re-do?) to make sure they execute. That will help narrow down the issue.

FarmBot should not launch the configurator network after a reboot. Instead, it should attempt to reconnect to WiFi and the web app with the credentials it saved from initial configuration. If the attempt fails and can’t successfully connect to the web app (or WiFi), only then should it launch the configurator network. If you would like to reconfigure, you can press the Factory Reset button in the Device widget.

1 Like

Sure thing! I hope this helps others.


Ill go about testing each sequence indivudually and then adding them to the chained sequence and see the results.

I have noticed that the error comes up at the same exact command in the sequence and oddly they all have the same variables when it comes to x,y,z positioning.

heres an attachment of the locations in the sequence where im getting the “failed to execute rpc_request”
sequence error location.pdf (255.9 KB)

I need to get photoshop installed so i can drawl on my images instead of uploading a pdf! :wink:

Thanks Gabriel,

-CMJl

Side note to my issue ( but not sure if related)

I keep getting this error whenever i tab back to the web app. It doesnt happen when im executing a sequence or anything else. only when i go back to the web app after being away from it for say 30+ seconds


If you see that message, you should refresh the page and make sure the connection is reestablished before trying to do anything. The Device widget should say connected to mqtt://mqtt.farmbot.io under NETWORK.

1 Like

@Cjaramillogrows
Sequences are looking good, in case you would drag new plants in your farm designer, you would need to import the coordinates manually again I think. But you’ve got it the right way so far.

@Gabriel

Today I also got this message for the first time. Everything was still working fine, I was connected properly to MQTT. Maybe this is a temporary issue?

@Ascend
Duly noted. FB wont automatically update the coordinates if i place a new plant down right?

@Gabriel so i think I’ve pin pointed exactly where the execute error comes into play.

See img for reference:

It happens exactly 1-2 seconds after the pump is turned and it begins to move to the, move Absolute position.

When the error occurs the Move Absolute command will complete and then the sequences freezes. at this point i just E-stop and re-sync and then 0,0,0 and re-execute sequences.

out of 5 sequence executions this happened on the 4th command but i do want to note that it doesn’t always happen on the 4/5 sequence execution. When i did another set of 5/5 sequences it happened at 1/5 and 5/5.

I’m going to try and execute the sequence without the wait command because it seems like thats when the error occurs.

Will be report after change is made and more tests.

Update:

@Gabriel


it was the wait command that was causing the error. (I don’t exactly know why though)

I made the chained sequence very lean with only three chained sequences - Grab Tool - Plant seed ( based on imported coordinates) - then put tool away.

I copied the chained sequence and had one with the wait command and one without the wait command in the Plant basil 1 sequence. Ran the sequence 12 times in total. 6 with and 6 without the wait command.

The 4th sequence out of 6 with the wait command encountered the error.
I further tested if 4 plant basil sequences could be chained without the wait command and I received no error at all.
I did the same thing for the chained sequence with the wait command and error reproduced.


Not sure if this is something the FB devs are aware of this.


all in all everything has worked good so far now that I’ve figured out why the error was happening.

Now my last issue:

When the chained sequence is being executed with more than 1 plant seed sequence I noticed that the FBs X and Y zero position becomes off little by little with each successful plant seed sequence. The more seeds I plant the more the X and Y zero position gets off set.


After a few plant seed sequences


What my X axis should be zero’d at

and same goes for my Y axis - after a few command runs the zero position begins to become off set from what it should be.


Again thanks for the help @Gabriel and @Ascend! :thumbsup:

-CMJ

Quick fix would be a short homing sequence after every seed plant. This would take more time but should prevent a crash between the vacuum nozzle and the seed bank.

Still I wonder why there are movement/positioning issues, when everything is monitored by encoders. So I will try to troubleshoot this from my sight (not using encoders myself):

  • Motor drives too far and encoder does not recognize that. Moved motor steps are with an offset (max missed steps) equal to the encoder steps.

Could you check the following things to check the encoder functionality:
->Hardware setting like max speed, max missed steps, encoder missed step decay and encoder scaling.

-> While moving or running one of your sequences, keep an eye on those values of the top two lines in the green box (motor coordinates, scaled encoder). If you need to you can enable them in the red box.

I assume that those values should be almost equal, but I don’t know if the encoder output is displayed in the right format (steps or mm?).