Farmbot Factory reset after update to 9.0.0

Hello , my farmbot is factory reseting since 1 week.
I disabled the automatic factory reset and the behavior still happening.
only happening when i perform an action , not when the farmbot is IDLE.
After i factory reset i loose access to the farmbot and i need to put again the wifi network.
I have no log identify the problem.

Thanks for your help.


Hi @danisam,

The CONNECTION ATTEMPT PERIOD that you have set is 1 Hour.
This is the maximum time interval allowed for the Bot to try / retry to connect to your WiFi AP ( which must be providing Internet access ) that you manually configured. After that period ends, and no Internet connection through that WiFi service was successfully established, then a Factory Reset is performed.

My bot has CONNECTION ATTEMPT PERIOD of 5 Days ( 7200 ). I have never changed this value.

I have a similar issue, but my "connection attempt field seems to be grayed out for some reason…

That field is unmodifiable until you set AUTOMATIC FACTORY RESET to YES.
You can then modify the CONNECTION ATTEMPT PERIOD and after that you can set the AUTOMATIC FACTORY RESET Boolean back to NO ( if you desire ).

@RickCarlino, Hi ! Could this issue be a lack of an initialization of the FbosConfig key network_not_found_timer for recently created accounts running first time on FBOS v9.0.0 ?

Hello FarmBot Forum!
(I have been a wafer too long…)

So, our FB G XL has been factory resetting after a motor action very consistently.
Each time, a full network configurator is required (go to bot, use wifi to config to wired network)
This had started with FOS 8.x at least, but since the bot has been idle over the winter, i can not be certain it was happening before.
I am suspecting the known areas that have caused us trouble before - Stepper drivers, Farmduino, RazPi.
We are using a Farmduino 1.4 that I thought was good, at least for the steppers, but other symptoms are making me have other thoughts: USB Cam is very slow to toast a msg that it took a pic, and then toasts that there was an error ("[take-photo] Problem getting image")
I had discussions some time ago with Rick & FB Co., and it was suggested to move to a Farmduino 1.5.
A bit at wits end, as we have a planting coming up, and it sure would be nice to have the FB move without a reset…

Hello , how could we move to Farmduino 1.5 ? @RickCarlino

Hi @danisam. I am investigating the matter now.

I just record a new diagnostic report for you to have more information.

Maybe this log also could help @RickCarlino.

This morning i reconfigure the network of my farmbot to have access again and try a Calibration and face another factory reset with those log messages.


@danisam I am still investigating and can see your logs remotely, but thank you for the additional information.
One thing I did notice about your device that was different than other devices: Until this morning, you had a very very low WiFi signal (~20 dBm). A FarmBot requires a connection that is consistently above 61 dBm to operate properly. It looks like you moved the device to a better location this morning as your WiFi signal improved. Did the device reliability improve also? Are you noticing any other peculiar behavior at this time?

I put an Wifi extender to give more signal to the farmbot.
No real change with my factory reset issue.

Hi @Intelbotfarmer,

The take-photo farmware had that issue and also Sequences would error out prematurely in the FBOS v8 series until v8.2.4. FBOS v9.0.0 ( current Release ) is also fine and includes those fixes.

Have you tried setting CONNECTION ATTEMPT PERIOD to 7200 ?

Just tried to put this value , but need to return home to configure again the network after a Factory reset that occurs today.

Yesterday after the change in the CONNECTION ATTEMPT PERIOD to 7200 i had another factory reset trying to move to a relative direction.
if the Farmbot is Idle , there is no factory reset.
hope @RickCarlino can help us in this issue. the farmbot is not usable that way.


Hi @danisam- I’m still investigating the issue. I found some related issues on the API that needed to be fixed this morning. Please try to keep your device online if possible, although I realize that the factory resets will make that difficult. I am able to see the logs remotely.

@dmbgo Are you still having the issue after toggling the “AUTOMATIC FACTORY RESET” button?

Hi @RickCarlino , i leave the farmbot connected idle , to be able to update the os.
Captura de Pantalla 2020-01-07 a la(s) 12.01.33


1 Like

@danisam I noticed you have auto sync disabled. Since you are having other issues currently, I would recommend enabling auto sync to prevent unrelated issues from appearing.

UPDATE: I have remotely enabled auto_sync and disabled auto factory reset. I will continue monitoring your device remotely. Please let me know if you would like me to set it back.

@RickCarlino, is ok for me.
Do you want i realize some test to see if i am going to factory reset again ?

Update: I will recalibrate the Axis and perform a watering sequence.



1 Like

Hi Rick, I toggled the "AUTOMATIC FACTORY RESET” button as jsimmonds suggested, and was able to set the timeout to 7200.
I’m not sure why my Farmbot loses its wifi connection periodically though.
I have replaced the wifi router and I think the signal strength is Ok now (it was a bit lower with the old router).

I could use a direct Cat5 connection to the bot, but I suspect that might be over kill?