Farmbot is offline while connecned to Arduino

The Farmbot goes offline (on page when Pi3 and Arduino connected by a USB cable.

Individually, both boards work normally, Pi3 goes online while haven’t connect to the Arduino, and Arduino success move steppers while haven’t connect to the Pi3 (I’m uploadable test sketch for the RAMPS, then I’m again upload firmware for Farmbot).

What could be the problem?
I’m tried different power supplies, USB cables, and Arduino MEGA2560 boards, nothing has changed.

Have you tried connecting with no firmware installed on the Arduino?

Have you tried changing out the stepper drivers?

Now Farmbot goes online (message “Farmbor is online and running” and “RoboFarm-APIK synced!” means that the device is online?), but no control commands for steppers does not work (the motor does not rotate).

If I connect the Arduino to the PC, I see a text meggases in console of Arduino IDE:
R21 P0 V1 Q0
R21 P11 V120 Q0
R21 P12 V120 Q0
R21 P13 V120 Q0
R21 P21 V0 Q0
R21 P22 V0 Q0
R21 P23 V0 Q0
R21 P31 V0 Q0
R21 P32 V0 Q0
R21 P33 V0 Q0
R21 P41 V500 Q0
R21 P42 V500 Q0
R21 P43 V500 Q0
R21 P51 V0 Q0
R21 P52 V0 Q0
R21 P53 V0 Q0
R21 P61 V50 Q0
R21 P62 V50 Q0
R21 P63 V50 Q0
R21 P71 V1500 Q0
R21 P72 V1500 Q0
R21 P73 V1500 Q0
R21 P101 V0 Q0
R21 P102 V0 Q0
R21 P103 V0 Q0
R21 P111 V10 Q0
R21 P112 V10 Q0
R21 P113 V10 Q0
R21 P121 V10 Q0
R21 P122 V10 Q0
R21 P123 V10 Q0
R21 P201 V-1 Q0
R21 P202 V-1 Q0
R21 P203 V-1 Q0
R21 P205 V-1 Q0
R21 P206 V-1 Q0
R21 P207 V-1 Q0
R21 P211 V-1 Q0
R21 P212 V-1 Q0
R21 P213 V-1 Q0
R21 P215 V-1 Q0
R21 P216 V-1 Q0
R21 P217 V-1 Q0
R21 P221 V-1 Q0
R21 P222 V-1 Q0
R21 P223 V-1 Q0
R00 Q0
R82 X0 Y0 Z0 Q0
R81 XA0 XB0 YA0 YB0 ZA0 ZB0 Q0
R82 X0 Y0 Z0 Q0
R00 Q0
R82 X0 Y0 Z0 Q0
R81 XA0 XB0 YA0 YB0 ZA0 ZB0 Q0
R82 X0 Y0 Z0 Q0
R00 Q0
R82 X0 Y0 Z0 Q0
R81 XA0 XB0 YA0 YB0 ZA0 ZB0 Q0
R82 X0 Y0 Z0 Q0
R00 Q0
R82 X0 Y0 Z0 Q0
R81 XA0 XB0 YA0 YB0 ZA0 ZB0 Q0
R82 X0 Y0 Z0 Q0

Are you able to send other commands? For example can you set Pin13 (the LED) to high? Can you share a picture of your electronics setup?

I have also encountered the same situation, Manual control steppers via, but X,Y,Z motor just Jitter…
Use Marlin code base to verify HW and it’s work.

Hey @JoeHou and @Tomasina,

check your jumpers for the endstops as seen on the picture below. I also had this issue and noticed that I unplugged those earlier. Maybe there was an update which made those necessary for movement.

Btw: [quote=“Tomasina, post:3, topic:1276”]
R81 XA0 XB0 YA0 YB0 ZA0 ZB0 Q0

means that all endstops are 0. So it looks like there are no jumpers, or if you are already using Endstops, they might be connected wrong.

1 Like

Great tip @Ascend!

The reason why you need the endstop jumpers is because the firmware has the endstops enabled by default. If you don’t actually have physical endstops hooked up to your RAMPS shield, then it is possible for the Arduino to think the endstops are being pressed when they’re not (because they don’t exist). This instructs the Arduino to not move any of the motors because it thinks it is at the end of the tracks or something. The fix is to add the jumpers so that the Arduino knows for sure that the non-existent endstops are not being pressed.

Hope that helps solve your problem.

1 Like

Good news!! it is workable if added jumpers , Thank you for your help!

A post was split to a new topic: Alternative Arduino Usage