FarmBot Not "Speaking" (No audio output)

I have recently updated to 13.1.0 and have been experiencing troubles with the audio output on the pi. After some digging, I found a previous forum post (FarmBot "Speak" ability not working) that suggests that this may be a FarmBot OS issue that occurred after I updated. I have tested the audio output by placing wired headphones into the jack and listening once initiating “speak.” This test had worked fine previously, but since the update, I have not been able to hear a thing.
This audio output is crucial to how we operate our FarmBot, so any tips or suggestions on how to get this back up and running is appreciated. I have a feeling it is most likely not a pi problem, as our setup was working perfectly up until this update.

@miar Thank you for bringing this to our attention. If it is critical to your use case, you may downgrade to version 13.0.1 or version 13.0.0 until we determine the cause of the issue. You will need to disable auto-update.

1 Like

Awesome, thanks. In order to downgrade, will I need to flash the pi SD card manually with one of the .img files you listed?

Also, if this is indeed an OS issue, it might be important to note that before the update to 13.1.0 we were running 12.3.4 on our FarmBot. Therefore, I am unsure how far back this problem goes. We only updated since v12 is no longer being supported.

Thanks again.

@miar Yes, you will need to do a hard re-flash (with Etcher) to downgrade. If you need to go farther back, we have a full list of releases here. You will want to use the files that end in -rpi-*.img for Express models and -rpi3-*.img for Genesis models. If the configurator does not come up, that is a sign that you downloaded the wrong .img file.

1 Like