FarmBot "Speak" ability not working

I have been trying to use the “speak” feature in a sequence, but am not getting any audio output.

I am able to create a simple sequence to speak a few words (and, of course, save and sync). When I click “Test”, the sequence runs and appears successful, but I get no audio output. I tried many things and eventually concluded that the pi itself might be bad, so I replaced the raspberry pi with a new one and I still get the same result.

I am trying to get the audio output via the headphone jack, as is indicated in the release notes about the “speak” feature. I suppose it could be possible that the sound is somehow coming out over hdmi, but I am not able to set the sound output device via FarmBot OS. Or perhaps volume is set to zero or something?? But, again, volume is not adjustable in FarmBotOS, so I would think that neither of these would be the issue.

Any help or similar experiences that others can offer would be appreciated. Thanks in advance!

@sven I have forwarded this issue to the team. We will keep you posted on updates. Thanks for letting us know.

audio should be sent out over the headphone jack. The raspberry pi’s audio jack is not amplified so it’s possible that everything is working, you just cant hear it. Have you tried with headphones as a test? i will look into making sure volume is max just to be sure.

Thanks for the quick responses.

Yes, have tried headphones as a test and can’t hear anything. Also tried connecting the headphone jack to the mic jack on another computer and listening for audio with audacity. This should have been able to pick up even things that were too quiet for me to hear, but it didn’t pick up anything. (I tested that setup by playing sounds to it from other devices and was able to pick them up without trouble.)

As a sanity check step, can someone else with a FarmBot create a sequence to speak a few words, connect headphones to your FarmBot, and “test” the sequence to see if you can hear anything?

If I can narrow this down to a problem that is definitely only affecting me (ie speak is working on other people’s FarmBots), then it will help me with troubleshooting the cause.

@sven I tried this last week with similar results to yours. We are still investigating the matter. I will keep you posted on updates. Sorry for the delay.

Hi @sven,

I did this test of a sequence with 1 command SEND MESSAGE and with both Toast Pop-up and Speak checked. Hardwired my little SONY SRS XB-20 speaker ( with Vol at Max ). The only sound was a soft background noise due to the digital circuits high frequency switching.
I did see the Toast Pop-up, but there was no espeak ( to speak of :slight_smile: )

This appears to be a problem in the version of Raspbian that was recently updated in :farmbot_system_rpi3.

I just tried a cmd-line test with lots of ALSA errors . . picture below

Glad it isn’t just me.

Re: the ALSA errors, I’ve seen on other (non-FarmBot) pis that sometimes you can get a lot of ALSA errors like that and still have audio output working. That being said, those errors are a good place to start, since clearly aren’t getting audio over the audio jack. Thanks for checking that!

1 Like

Hey @sven, noticed ( just now ) that your post is not associated with a Forum Category !
Very Interesting ™ :wink:
Otherwise, maybe, that process of assigning an association, is a carbon unit ( Human ) one ?

Looks like it was a human issue… these will become less prevalent as the robot race replaces us less optimized organisms. :wink:

I was able to go change it to Troubleshooting.

I saw a new update to FarmBot OS, I don’t suppose the speak ability is fixed in that update?

Any progress on this? My first guess would be that it is not outputting audio on correct device.

@sven, I just checked . . there’s silence on the HDMI audio channel also.
Those ALSA issues are the root symptom of the problem I believe.
You won’t get far if you can’t configure a sample rate for a stream :expressionless:
Expression 'paInvalidSampleRate' failed [ . . . ]

Maybe @RickCarlino has some news ? There will need to be a fix for the Linux OS package.

1 Like

This issue is on our radar for immediate work. Unfortunately, there are a few issues infront of this one that @connor needs to address first. We will keep you updated as details emerge.

1 Like

Thanks. I will keep trying to troubleshoot it on my own in the meantime, but I think that probably means a custom FarmBot OS image at this point.

Will post here if I figure anything out that might be useful.

@sven, the latest FBOS Pre-Release has attempted to fix espeak . . but hasn’t. :hole:

1 Like

@jsimmonds Thanks for that note. So now that Pre-release has some audio, but it’s choppy and out of HDMI. If we can get choppy audio over the headphone jack it would serve my purposes well enough. Looks like it’s pretty close.