Farmbot problems connecting to arduino ramps code 30

Hello all i have again and again trouble with the connection between farmbot and arduino ramps.
error code 30
Farmbot on zero w
Version: v14.8.1
Model: Express v1.0
Flashed Firmware on the arduino ramps with arduino ide and the hex provided in the farmbotOS.

On the pc i can connect and send f83 witch gives me the firmware version of farmduino/ramps.

But the farmbot zero w doesnt find it.
The arduino ramps is connected to usb otg and recognized on ttyUSB0
i chosed this under FIRMWARE PATH in the settings.
When i try to flash the farmduino/ramps from the it corrupt the firmware ( can´t comunicate with the board on a pc.)

ps. the ramps is selfpowerred and ok checked 2 of them
the power for the pi is also suffizient.

Anyone has these problems?

Greetings from northern Germany

1 Like


Do you own an actual FarmBot Express? Or, are you trying to load the software onto an Arduino RAMPS setup?

I would be helpful if you could post a photo of your hardware so that we can see it.

If you are using an actual ARDUINO Mega micro-controller you will need to select “Genesis v1.2”

Learn more about how to connect the Raspberry Pi to the ARDUINO Mega.


1 Like

Its a Ramps setup.
i know i have to chose the ramps/genesis 1.2
it worked one (see picture one) time but after a power down it doesnt work again (see picture in next post).
and yes on the picture of the hardware the arduino ramps was not powered external.


Apologies for the confusion. You will need to use a Raspberry Pi 3 or Raspberry Pi 3B+.

I may be mistaken, but I don’t believe that you can use the Raspberry Pi Zero for the FarmBot Arduino RAMPS SHEILD as in the Genesis v1.2 configuration setup. In order to use the FarmBot Genesis v1.2 firmware you must use the Raspberry Pi 3 or Raspberry Pi 3B+.

There are likely firmware issues preventing from you from connecting to the Raspberry Pi Zero.

I dont understand why it should be a problem depending on which pi i use.
I can connect to the zero and reboot the system but the zero farmbotOS part doesnt find the arduino ramps, but its there i can see ttyUSB0 comes up on boot and or hot plug with monitor connected.

I would recommend you to set debug message levels to the highest level and watch out for suspicious log entries. You should be able to see a similar log message like this to make sure that the serial path(s) was detected by the OS aswell:


But notice that debug logs are gone when you refresh the Website!

Switching between Rpi0 and Rpi3 is intended to work AFAIK, thats probably the reason why the firmware path function was made. Here is the long story.

1 Like

there farmbotos try to flash.
think before it must happend that the Firmware in arduino/ramps bricked.

have to reflash the arduino external again and watch what happend when it has a working firmware in the mcu.



Please trust me when I make the recommendation to use a Raspberry PI 3 or 3B+ rather than a Raspberry Pi Zero. This is the computer hardware that is used for the FarmBot Genesis v1.2. You are more than welcome to play around and try to get it to work with your Raspberry Pi Zero, but you will likely have better success if you take my recommendation and use Raspberry PI 3 or 3B+.

As you can see from the Graphic below, the Raspberry Pi Zero is used on the Express hardware, and that requires a different FarmBot OS version.

1 Like

the express 14.9.0 is installed on the pi zero w sdcard. ( the genesis version dont boot (i dont know why nerves is be used…)

in the setup of the express image installation you can choose between all farmbot models. none of them work. (genesis 1.2 worked once till reboot)

if i fake the Firmware output (f83) from the arduino from: 6.5.35.R.genesisK12 to 6.5.35.E.expressK10 its the same problem.

i think it has to do with the software witch handles the usb connection to the ramps.

That’s correct. Genesis bots use RPi3B to run FBOS which uses a different Nerves System ( buildroot configuration )

I’d love to help you . . I have RPi0W but not Arduino-RAMPS . . which Arduino-RAMPS model are you using and where did you buy it ? I’d like to try one. I believe RPi0W should handle ttyUSB0 Ok for firmware comms.

1 Like

I thought so too, but there seems to be a problem.
the Board is from a 3D Printer (look at post 3) it´s basically a ramps v1.4.

@DennisT can you borrow or buy a known good Arduino 2560 to test with ?

Yes i can test with a original arduino Mega without ramps shield. But Think will be the same. Have a handfull of The Printer boards (all same typ) 3 testet-> all 3 With same Error. In a 3d Printer they
all work.

Did you install the bootloader on those boards? Mine does not and it seems like past versions of Creality boards also don’t have it. AFAIK you can’t flash boards without bootloader over the usb port.
Also please double check if your Arduino board does have a Mega 2560 chip installed, mine (Ender 3 v1.1.3) uses a Mega 1284p that most likely will not run this firmware.

I just tested the same setup using a Rpi0W with a Ender 3 board 1.1.3 and got a similar behaviour. FBOS is receiving mesages, but all the sent messages are timing out. I also can’t flash via Arduino IDE so I think in my case the reason is that I don’t have the bootloader yet. Also I noticed afterwards, that the Mega1284p does not run this firmware.
Check spoiler below for pictures.


Edit: Just connected a regular Arduino Mega 2560 via USB. Flashed like a charm. Issue must be on your printer boards.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.