Fb does not connect to the wifi network

@connor Can you help me please?
fb arrived 3 weeks is all right to work, but not connecting to the internet.
all data is correct and firewall unlocked, after fb does not connect to the farmbot-xxxx network generated for setup does not appear, just powering down and on again

How are you seeing Farmbot power down and on again? Are you able to get through the entire configuration utility? After the initial configuration, the farmbot-XXXX ssid should not come back if everything worked correctly. Your web browser is saying connection refused to our message broker, so it could be a firewall or dns issue with your internet service provider.

yes, after not setup, the farmbotxxxx network does not return, and fb does not connect. To provide the farmbotxxxx network I have to power off and reconnect the raspberry.
however I have been able to connect to 13 days ago, I will review all causes of error getting new information I will post again here thanks.

This seems to be a common problem with 6.4.3 by all the “can’t connect” threads. I fixed mine by going back to 6.4.0 where everything synced up right away.


I’ll try to install this version thank @HighlandGrey

@connor @RickCarlino
installed 6.4.0, fb continues to perform setup normally but does not connect, farmbot-xxxx ssid only returns restarting raspberry.
Having that fb managed to connect 13 days ago in the same conditions today.
firewall ok
wifi settings ok
google chrome browser ok
websockets (port 443, ssl) ok
What other errors do you recommend to analyze?
how to know if the error is dns?

@connor @RickCarlino
websockts port 80 problem , this may be the cause of FB not connecting to the wifi network?


I noticed in your second screenshot that you are using an HTTP proxy. We have not tested the application against proxy users, but that might not cause any issues since it looks like the issue is with FBOS rather than the browser or server. It could be a problem if your network blocks access to ports that FBOS needs, such as 5672 (AMQP) or 123 (NTP).

I am going to forward this to @connor when he gets in to work today- we may need to get some diagnostics off of the device to see what happened.

thanks @RickCarlino , I’m awaiting

My problem is that after mounting FB, it usually connects to version 6.4.3. 19 days, as shown in the picture circled in green. but did not send messages from the broker because the firewall was blocked, so I asked my server to release all the ports.

but when the firewall was ok, raspbarry could no longer connect to the wifi, the configuration usually runs without error message, but it does not connect and the ssid farmbot-xxxx does not update to new configuration, I have to disconnect and connect it back to show the ssid

@VitorAffonso Please try the following:

  • Unplug as many peripherals from the device as possible (eg: Arduino)
  • Power the device and wait one minute or so for bootup.
  • Plug a USB drive into the Pi
  • Unplug the USB drive and check for a *.txt in the USB drive
  • If you do see a *.txt file, please send it to me as a private message. These are your bot’s error logs. They will help @connor and I get a better picture of what’s going on.

I removed all the peripherals of the pi, restart after 1 minute I connected the usb drive but 1 minute I removed and I opened the drive in the computer but nothing of * txt

leds of pi
solid red
green flashing

@RickCarlino @connor I connect the pi to a monitor and report the information generated on the screen helps to know what is happening?

What version of farmbot_os have you burned to the sdcard? That is a pretty recent feature in only the latest version if i remember correctly. You can try connecting Farmbot to a monitor, i can’t remember if any useful data will be available. If there is data, you can take a picture of it and private message the data to either @RickCarlino or myself. I’m beginning to suspect your raspberry pi may be faulty if it is not populating logs on the flash drive.

I’m using 6.4.3, also suspect be the pi because it usually connected to 20 days. and does not generate configuration errors.
I’ll format the pi and install the raspbian and see if it performs all the functions and connects to the wifi

Hi @RickCarlino @connor , I need a detailed list of all the ports that can prevent the FB connection, today I ran tests with PI on the home wifi network and it worked without problems.
firewall of the company network that the FB is already ok so I need more details to investigate what is causing this.

@VitorAffonso A list of required ports is available here: https://github.com/FarmBot/farmbot_os/blob/a444248f05ee8f4fe57f6a4865b942131960f76c/docs/FAQ.md#what-ports-oputbound-does-farmbot-os-use

@RickCarlino @connor now I have another problem, after connecting the PI in home network today when trying to connect in the company appeared this message error