Gantry “stutters”. Does it need more torque?


#1

Hello FB Forum folks - Houston has a problem. (Actually, we are in CA, but you get the point)
When I send a “move” command to the X-axis, the gantry will start to move, then stops. It will do this three times, then abort. (Max retries” is set to 3).
Here is a link to a video of the behavior.

(If the link does not work, try cut-n-pasting this into your browser “https://www.dropbox.com/s/yr73vjkit5hoji4/1080p.mov?dl=0”)

My first thoughts (and actions) were to:
1). Equalize the gantry. Done, same error.
2). Verify all wheels were adjusted correctly. Done, same error.
3). Verify that the rails were even for the entire length. Done (added shims to adjust), same error.

I am thinking that I either need to tweak the motor settings or swap out the X-motor gears for 14 or 12 tooth gears. (Does this require new belts?)

Also, it looks like one of the encoders on the RazPi is burnt, but I swapped it with the “spare” (unused) encoder. I am not sure if this was burnt from the get-go or happened after first power-on. I will order 5 more as soon as they become available (currently show “Sold out” in the FB store.)

Any thoughts or advice would be most welcome…


#2

Hi, I had some trouble w/ the gantry stuttering then stopping.

Assuming you’ve tried the steps on this page:

The one other thing I found was lower accelerations and lower stepper driver output helped avoid the problem. I ended up w/ acceleration of 450 steps to max rather than the default of 300, and I also turned the voltage down to ~700mv on the x and y axis. (And needed increased power on z or else it wouldn’t move up.). This was after turning the power up and making the problem worse.

Not sure if this will help, since from the video it looks like one side is getting ahead of the other. (Maybe verify the power on both stepper motors is the same?)


#3

I also noticed, that one side seems to run ahead of the other which could be caused by either too low or too high driver output power.

You are not using a solar system right?


#4

@I_Kill_Plants
Thanks for the info…
Unfortunately, I think our problems may be worse. It looks like one of the encoders fried, and I am hoping the Farmduino is not compromised.
But, I was also thinking of “equalizing” voltage between the two X-axis steppers, but i was thinking that the voltage had to go up. Good to know what you found out! Thanks for sharing that!
I will post back on this after I have either more info, have root-caused and/or am back up and running.


#5

How do you change the power output? within the software?

My X axis is very jittery also. Have tried so many things such as squaring cross beams and the beams attached to what would be a raised bed. I have played about with speeds, acceleration, changing the axis length within the software. Originally Both of my motors that control the x axis were going in opposite directions but inverting the encoders fixed that.
Nothing seems to be working in regard to the axis being jittery though . Any more ideas?

I feel as though because there are 2 motors controlling the one axis if the 2 motors are not talking to each other in someway, the motors can receive pulses at different times causing one to start moving before the other meaning the alignment of the gantry ends up being out. If one of the motors loses a pulse and the two motors aren’t talking to each other it could cause one to be ahead of the other and the other one won’t catch up as it doesn’t realise and this could cause the jittering?


#6

Your motors were driving in the right direction, but the encoder reading was wrong? Only inverting the encoder
usually would not change the rotation direction of the motor, there is an extra toggle for that.

The output power is set in the stepper drivers that are plugged into your arduino/farmduino. Just follow the guide on I_Kill_Plants link above.


#7

I have followed each of the steps within the link and nothing has changed. It is still stuttering. Is there anything else i could try?


#8

Was there the same behavior in terms of stuttering or did this issue appear when you inverted the encoders?

Try to loosen up your belts so the motors can run free. Now move the axis with the webapp and check how the motor shaft is moving. Usually only one motor does that stuttering and blocks the other motor through the mechanical gantry equalization.

No matter how this went, you could try to swap the stepper drivers on your farmduino with another axis that is working.


#9

I inverted the encoders because one motor was trying to go one way and the other motor was trying to go the opposite and therefore obviously stall. I will try swapping the stepper drivers now.


#10

I have loosened the belts of the x axis motors and the motors are very very easily stalled. When i put a bit of pressure on them with one finger they judder and a bit more pressure will cause it to stall and stop completely. Is there anything i can do to stop this, is there a way to add power to them?


#11

In that case an inversion of the motor direction is needed instead of the encoder direction. This could probably lead to similar behavior.

If you turn of the encoders you can see if the motors are running in the same direction.


#12

i have managed to fix the problem. The drivers needed a hell of a lot more power.

The only time the axis stalls now is when the wheels go over the joint in the profile. I have filed all burrs and the axis is lined up properly as went through all that trouble when trying to get the stuttering to stop.


#13

What did you set the power to?


#14

close to the max recommended


#15

The potentiometer screws on the drivers have a flat face on them and that was facing 12 o clock, i then turned the the screws clockwise to about 2 o’clock and the motors seemed to get a lot more power through. It felt much harder to stall the motors using my finger when the belts were unattached.


#16

Can you measure the voltage with a meter?


#17

Sorry mate, 0.850v for the 2 x drivers and 0.650v for the y and z drivers. If i go any higher than 0.850v on the x drivers they don’t move at all. I still find that when the gantry go’s over the joint in the tracks it tends to get caught or stall.


#18

https://youtu.be/89BHS9hfSUk this youtube video is what i used to help me.