Hidden SSID not connecting

Does anyone know of a way to add a hidden SSID? My network admin allows a connection without a user name but the configurator doesn’t connect to the hidden WiFi when added manually. Any suggestions?

Shouldn’t have to supply a user name when connecting to a WiFi network, just the SSID and WPA2 passkey… If there are extra layers of security on your network (VPN perhaps?), then you’ll need to coordinate with your network admin to see how FB can be given access without that credentialing. AFAIK, there is no way for FarmBot to connect to a network that’s protected over and above WPA.

Also, remember that hidden SSID’s need to be typed in case-sensitive-ly. Perhaps that’s an issue.

Thank you for the suggestions. I double checked the SSID and the case is correct. It just doesn’t seem to connect to the network at all despite everything checking out including the type of security and everything. I’m at a loss for as what to do…

Thank you for reporting the issue. We have identified the bug, which will be fixed in the next release.

1 Like

was this solved? I couldn’t connect my farmbot to hidden wifi. It could connect when the wifi is visible, but whenever I made it hidden, the farmbot wouldn’t connect.

@CCNY-farmbot are you testing only on 2.4GHz band ?

Although the RPI3B is only able to access 2.4GHZ, it shouldn’t matter if the wifi point is hidden, with the same access point name the the 3B was initially configured with. Things to check:
Is the name of the access point exactly as it was before hiding?
Is the Access point configured to use 2.4GHZ?
Can other WIFI devices connect to this access point using 2.4GHZ and the SSID that you have configured the Farmbot for?

Ah! I see what might have been going on. I used a TMobile 5G hotspot, which automatically configures 5GHz and 2.4GHz when devices connect to it. other devices could connect fine. let me change the WiFi settings and try again.

Thanks for the tip. Let me change the settings and try again.

I tried to change the wifi to 2.4GHz, but it didn’t work. Once I hid it, my farmbot lost connection. Other devices could connect to it fine. I wonder if it had anything to do with the T-mobile’s 5G gateway that I was using: 5G Wi-Fi Gateway for High Speed Home Internet | T-Mobile 5G Home Internet

I’ll do some testing here ( down-under ) and report back.
Curiosity question : Why hide the SSID ? ( doesn’t add much “security” )

I doubt that, but I’m ready for surprises :slight_smile:

@CCNY-farmbot I can reproduce your issue ( ASUS ZenWiFi AX XT8 on Guest network with “Hidden” SSID )

May not be a “FarmBot Inc.” issue as such but a problem with software that FBOS depends upon :slight_smile:
( VintageNetWiFi ) . . but I’ll also do more digging into the problem.

Maybe you could make polite enquiries over there ? ( and mention this forum thread )
GitHub - nerves-networking/vintage_net_wifi: WiFi networking for VintageNet

Long story short: we are on a university campus with strict rules about “rogue devices”. While waiting for IT to connect us to the school network (opening ports for FarmBot), we need a temporary solution without bringing too much attention to ourselves :wink:

1 Like

@CCNY-farmbot I did one additional test (below) and the issue appears to be with VintageNetWiFi.

  • Configured a 2.4GHz Guest AP with hidden SSID
    . FarmbotOS unable to bring WiFi network up.
    . VintageNetWiFi.quick_configure("<actual Guest SSID>", "<passphrase>")
    = unsuccessful
  • Set that 2.4GHz Guest AP to broadcast SSID
    . Both configuration methods succeeded

edit - NB

@CCNY-farmbot After more thought and reading, seems it could be a FarmbotOS coding issue . .
See vintage_net_wifi/README.md at main · nerves-networking/vintage_net_wifi · GitHub
and look for the :scan_ssid probing option.

I’ll do more testing :slight_smile:

FWIW: We were never able to adequately solve the problem with conventional solutions. The amount of frustration we experienced was nerve wracking due to the fact that we had a ~$3000 brick. Eventually, we bought a Wi-Fi repeater, connected it to the hidden SSID and gave the repeater an inconspicuous SSID (FARMBOTWIFIDOESNTWORK) and connected to it via the normal method. Don’t know if that is the solution for you but it got us up and running.

@CCNY-farmbot @Clarkindustries I’ve found the coding error in FBOS just now ( don’t know yet how the error happened . .i.e. whether there was a breaking change in the VintageNetWiFi package dependency )

I don’t work for FarmBot Inc. so if you need the fix quickly, you may need to talk to Rory.

edit -

Pull Request with fix submitted today.
Update validator.ex by jsimmonds2 · Pull Request #1500 · FarmBot/farmbot_os (github.com)

1 Like

@CCNY-farmbot @Clarkindustries
This fix has been released today in FBOS v15.3.2

Thanks! I will update and try it out.