Message broker (MQTT) connection issues

Hi, what’s the reason, I don’t understand?

Your web browser is unable to connect to the message broker (MQTT). You might be behind a firewall or disconnected from the Internet. Check your network settings.

This message appears when communication between the browser and the device has been interrupted. As the message says, this could be due to a firewall blocking the communication or a network change.

Refresh the page and check the MQTT status in the Device widget to confirm any issues.

It’s also possible your browser doesn’t support websockets. Make sure this websocket test passes.

Is this a success?

Hello, my device has this problem, I want to ask you, what exactly should I do?:disappointed_relieved:

Is it my home wifi problem?


I also started seeing this issue about the same time as xiaorong. I’ve tried across three different browsers, each on a different internet connection, including on the one I’m currently writing this. Here are the results of my browser running the afore-mentioned websocket test:

Is it possible someone has taken control of my farmbot? My farmbot currently is on my network with a DNS name of “nerves-de01”. I named mine “fuzzyfarmer” upon intital configuration. Also, if I go to the IP address assigned to that name, the Farmbot Configurator appears on a non-secure connection.

I’d appreciate any insight you have into this very odd behavior.


A DNS name of nerves-de01 is normal. Currently the DNS name cannot be changed, so what you are seeing is the default name (which may change to farmbot-xxxx in future versions). Your custom device name is used in the web app and in FarmBot OS. Viewing the FarmBot Configurator (view-only) at the device IP address is also normal, although that will change in future versions.

What exactly are the issues you are experiencing with the message broker connection? Are you not able to communicate with the device? What does the Device widget show? If you refresh the page, do the issues resolve?

Thanks Gabriel for the explanations.

The web portal will essentially spin the color wheel forever, and upon initial refresh, I see the same error message like hx244808 as well as “error downloading data”. See below image for the Device widget. This same scene appears no matter the web widget (Account, Controls, etc).

I have seen these exact behavior across three different internet connections and computers. I have tried hard refreshing the browsers on all three, but there is no effect.

That looks like a web app login or connection issue. What do you see when you navigate to

It immediately redirects to “”. Here’s a screenshot.

Can you click on MENU (in the upper right), then click LOGOUT and try logging in again?

Done. It looks like there is another firmware update (5.0.2). Not sure why it didn’t autoupdate (I did have that setting set). Perhaps this is the source of the issue. 5.0.2 is downloading now (see below).

You guys are doing an amazing job managing this project and I want to say thankyou for all of the hard work! My negative experience with the update cycle may be a one-off, but if there is a way to address this “psuedo-bricking” that occurs during each firmware cycle, I would be very grateful.

I’ll let you know what happens after it updates.

OK, finished the update. I am still getting the spinning wheel and the same message indicating a problem downloading data when attempting to pull up the control page. All of the other widgets/pages seem to be working. Once I attempt to re-open the controls page, all widgets stop responding (the address bar will change but no changes to the DOM/web page appear).

More info: the famrbot will not respond to calibration requests.

I don’t think the controls page issue is with the firmware update, but you could re-flash the SD card to rule that out. We’re looking into a possible bug regarding the webcam widget on the page. If you avoid the controls page are you able to control FarmBot? Does the controls page load once, or not at all? Thanks for providing the screenshots and information about the issue.

Glad to help Gabriel. I attempted to use a sequence to control FarmBot and was unsuccessful. The sequence widget did successfully send the sequence request to FarmBot with no errors, and then indicated the sequence was complete. FarmBot however, did not move.

I did avoid the controls page entirely using a hard refresh. The widget also indicated the “Error downloading data.” message.

I will try re-flashing the SD card later today.

If you get the Error downloading data. message, it likely means that you are not logged in to your account properly, so other functions are probably not going to work. You will need to login in again.

If the log still reports movement, but FarmBot isn’t moving, check the power and wiring to the motors. This does however mean that FarmBot is receiving the messages you provide.

Since you mentioned credentials may be the case, I attempted a factory reset this evening. This produced:

  1. FarmBot will no longer connect to the web app.
    (See first screen shot)

  2. The log files show some very odd timestamps for some activity. I was most definitely at work during the indicated timestamps, but the minutes portions are pretty close to when I performed the factory reset. This is rather perplexing. Any thoughts?
    (See second screen shot)

  3. To help get more data points, I used a different web browser (one I never use) Microsoft Edge. This produced the same “Error downloading data” issue (see screenshot 1)

  4. It appears a new firmware was pushed last night. FarmBot saw it, but did not perform the auto-update as it was configured to do.

Screenshot 1

Screenshot 3

At this point, I may be at the end of the road as I now have no control over FarmBot and cannot coerce it into downloading its new firmware. I’ll have to do a manual re-flash. It’s storming here now, so it may be tomorrow before I get to it.

Latest efforts.

A manual reflash did not fix the problem, symptoms have remained the same (the biggest two being “Error downloading data” and navigating to the controls widget locks up the web UI.)

An interesting new piece of information: FarmBot thought there was a newer version of the OS (5.0.2) even though that was the one I flashed manually. See screen shot.

More data: Upon FarmBot downloading and installing the 5.0.2 on it’s own, nothing changed. It also thought that an updated version of the OS existed and proceeded to download it.