MiFi devices - trying but failing with old Huawei E5830 device


#1

It has to be quite close for it to see it (probably largely due to the other wifi networks nearby that seem stronger).
When it is close, it shows on the FarmBot configuration scan, and seems to accept the configuration, but FarmBot never shows up on the webapp as connected.

And it does not re-appear as the farmbot network - which seems to imply it thinks it should be able to connect.

This MiFi only supports 3G, so perhaps its too slow for the FarmBots needs.

The manual can be found here, if that helps - https://www.manualslib.com/manual/378023/Huawei-E5830.html.

Hopefully we will get an ethernet link sorted soon, so won’t need to do this


#2

PS I tried configuring it with both WPA and WPA2 security - neither worked.
Presume the “open” / no security option does not work with the FarmBot OS yet.


#3

At the moment, Farmbot only supports WPA2-Personal networks.

Regarding speed, 3G or 4G are not necessarily indicative of your throughput. Each generation has a ballpark range of throughput speed, but nothing is really guaranteed. That said, I doubt Farmbot consumes a lot of bandwidth, and I’m confident Farmbot would even operate perfectly fine on a 2G GPRS or EDGE connection. YMMV.

Can you explain what your Huawei device does? As I understand from your original post, the device creates a WiFi network and connects to a 3G mobile network for internet connectivity?

If so, you should first troubleshoot if you are indeed able to use the Huawei device to use the internet with the WiFi network it creates. Before hooking up the Farmbot to it, first use something like your mobile phone’s WiFi to connect to your device, and see if you have internet connectivity through its 3G connection. This will confirm the Huawei device is actually working.

After that, hook up the Farmbot, ensuring you are using WPA2-Personal security (as explained by @RickCarlino above).


#4

Thanks - the device has 2 WPA2/PSK options - was using the AES one. There is also TKIP.

Will give that a go.

As you guessed, the device creates a WiFi network, connecting to a 3G mobile network. This works fine from my iphone - I can browse the web ok.