Motors to weak/loosing steps

Hi everybody,
we just assembled our farmbot Genesis 1.4 and wanted to do our first movements with the manual moving section in the web app.
What we first noticed is the follwing: Z-axis movement was really noisy.
Upon further inspection we found the motor to be the source: It´s skipping steps and also beeing really weak.
We tested the reference voltage of all the stepper Drivers: 1V
We switched motors, cables, Drivers back and forth and the Problem persisted. Also we removed the Encoder Connection. We also used a similar motor without Encoders on the same Setup. We recognized that all four motors are not giving much torque, meaning you easily stop them by Hand. In case of the Z-Axis even the weight of it seems to be enough to cause Problems.
We tried to increase the voltage of one stepper Driver, but without success. Maximum we could reach was around 1.2V before automatic shutdown and also they are already relativly hot, even if the motors are just Holding their Position.
Questions:

  • Any suggestions for Troubleshooting/ideas for reasoning whats wrong?
  • How much torque are These motors supposed to produce?
  • Are they using full power when Holding their Position?
  • Does the power supply work properly with german Standards (50Hz, 230V)?

Greeting and thanks for all Help,

Martin

Guten Morgen Martin
to start with, I don´t have a farmbot yet but I have been building my own gantry-based cnc stuff for a while. In general it does not make a great difference whether you move an irrigation nozzle or a drill into the right position. So first thing you want to make sure that there is no mechanical problem. Can you easily move the z-axis up and down with the farmbot powered off? If not, voila! The NEMA 17 steppers are in my view really weak and I always pick the size of my steppers so that under worst case conditios they should be able to move the system and it works well. Also I usually buy closed-loop steppers (also called easy servos) as they consume less power when in idle. That is for all systems where a user is present during operation so a version running 24/7 would have at least the same power reserves.
So you are right assuming that normal steppers use the max power and have the highest holding torque (which is usually what they come labelled with). But in the case of the z-axis something must be stuck otherwise there is no more power available to raise the thing. Guess the farmbot guys have spent sufficient time to make sure this doesn´t happen with a new machine.
If you can, I recommend to disassemble the z-mechanism completely even if it came pre-assembled out of the box. Mistakes happen and I just lost two hours recently because I was sure I had tightened a bolt on a timing belt wheel but I had not but I was too lazy to check cause it was hard to access.
The power supply can´t really be the problem, most modern devices deal with 50 and 60Hz and 110/230V but that should be on the label, too.
I am thinking about buildung a bigger farmbot using only the farmbot controls and software.
Where are you located in Germany?
best,
Niclas

The Z-axis uses a “lead screw” rate-reduction gearing . . can this actually be moved manually with all power off ?

( I don’t have a FarmBot device ( yet ))

Yes as they are not self-locking.

Hallo Niclas,
thanks for the Reply. Of Course I´ll recheck the mechanics, but without much hope :wink:
A device consuming maximum power when really doing Nothing kinda Freaks me out, but what do I know.
I´m located in Zittau, so just at the other end of the republic, but still, feel free to ask any Question. Also theres a WhattsApp Group with Germany based users I could Point you to.

greetings,

Martin

I agree with that, if your motors won’t even move properly without having any hardware connected I don’t see much hope.

The Z-axis is always much more noisy than the other ones (leadscrew grinding in its nut). The only way to reduce this cheaply is by activating microstepping for this axis. 1/2 stepping should be enough, since you lose torque with increased microstepping rate.
Now that I’ve called something about microstepping … How are your dip switches set on the farmduino? By default they should be set to OFF. Reference documentation from the software docs.

Click here in case you don't know where they are.

image

Hi everybody,

we did some further tests. First we had one of the motors connected to a friends 3D printer. He reports it was spinning nicely and much stronger compared to when connected to the farmbot setup. So this for me means the motor control in our bot is not working properly.

This is how our motors work:
video of motor turning
They loose steps, vibrate a lot and don´t produce much torque.

Here we did a measurement of the voltage at the steps finger of the driver:
video of voltage measurement
Our electrician told us the jitter is not supposed to be there. The sequence shows ramp up, maximum speed and ramp down.

Could it be that the farmduino or the firmware are producing this odd behavior?

Greetings,

Martin

Hi Ascend,
thanks for the hint. At the moment all switches are off. We also tried to change stepping (successful) and the lower speed indeed reduces the odd behavior of the motors a little. But since they are still not working properly this is no solution.

Martin

Totally right, that really should not happen. I’ve seen this behavior many times before and it was usually caused by bad drivers (a4988 are really cheap, often low quality and faulty shipped) or a bad connection between motor wires.
But since this issue persists on all motors (low torque) there might be something wrong with the farmduino.

Are there any comments from the farmbot team on this? Maybe something similar has happened before?
I also would be glad for pointing out the right channel of communication to get this issue resolved.

greetings,

Martin

We might ask @Gabriel and @roryaronson if this has happened before :slight_smile:

@mherling have you tried adjusting the motor and encoder settings in the web app? I’d first disable encoders and focus just on the motors. Try lowering the max speed, and increasing the number of steps taken to accelerate. If you get the motors running smooth with some of those adjustments, re-enable encoders and try tuning their settings: increase max missed steps by 30% or 50%.

For the mechanics, try loosening eccentric spacers a bit, dry lubricating the z-axis leadscrew/leadscrew block, and maybe loosening the belts if they seem too tight.

If none of the above helps, there may be an issue with your electronics. If that’s the conclusion we come to, please follow up in the DM you sent me with your shipping address and we’ll get you the appropriate replacement parts.

Thanks for the detailed troubleshooting information you’ve provided, hopefully we can get your bot up and running soon.