My.Farmbot.io connection issues


#61

ahhhh yes the screws on the stepper drivers! I forgot about them.
Great!

As far as the moment being incomplete.
It’s within the web application. The top section where the Farmbot gives you a response after commands have been input.

For example:

"[FILTERED]
10:48 am
TreeGrowth Completed movement: (-200, -1100, -200)
10:42 am
TreeGrowth’s arduino says: stopped
10:42 am
TreeGrowth’s arduino is busy.
10:42 am
TreeGrowth’s arduino is busy.
10:42 am
TreeGrowth’s arduino is busy.
TreeGrowth’s arduino says: stopped"

ive gotten the bot to move from left to right on the Y axis 100 across the length of the track so that has been fixed at this point.

The next step for me is to make sure the X axis motors work with full movement.

@Tim

Do I turn the stepper driver screws to the left or right to increase output?

Also, i should turn off the Farmbot for these adjustments yes?


#62

I never bothered with turning off for turning the screws. No idea with direction, I just fiddled until it worked. But in the new version, the z axis is always powered, so adjusting the Z might be a bad idea when turned on.

I can’t comment on the messaged on the controls. I use g-code directly for testing purposes mostly.


#63

Got it,

Well, thank you for your help @Tim.

keep up the good work, you guys are awesome.


#64

我登入这个里面,我的界面出现啦这样,我要怎么弄呢


#65

I’m also having problems with the connection, the IT department at the company needs the port that they need to set open because normally everything is blocked. it could also have something to do with the wpa2-personal/work thing but they are not sure. I hope you could help me out!

Thanks in advance!


#66

@ghgfarmbot

Do you have direct access to the Internet at your company?A lot of them are using some kind of corporate proxies which could also be the problem.


#67

That is probably the problem, but they said that if they have the port number they can set that port open and that it might solve the problem.


#68

Farmbot OS uses https for the backend systems and NTP for the time synchronization. Hence they’ll need to open the following ports for outgoing connections:

  • tcp 443
  • udp 123

Never the less we should open a ticket in github to add proxy support in the future. Can someone please do this? I’m still waiting for the approval of my employer to sign the CLA ^^


#69

Farmbot OS also uses MQTT, and WebSockets. Selectively opening/closing ports will probably be pretty difficult.


#70

I’m still having problems.
Yeah I understand, I try to work something out with the IT department to get an open internet connection.

For now I have some printscreens I took which might give you some more information.


#71

I’m also experiencing connection problems.

When booting from a fresh 3.1.5 for the first time, both configuration and connection through the web app work as expected. I can move the bot and everything. After poweroff and restart, however, the bot is reported to be offline.

Similarly, the bot is reported as offline after a emergency stop. And after a reboot triggered through the web app.

EDIT

I have tried to further narrow down the problem, and it seems that the pi does not reconnect to the wifi. Using the app ‘LanScan’, the pi initially appears in the list of devices on the network, but after reboot, it no longer does.


#72

booting with 3.1.5 for the first time went well.

for two days I have had the screen pasted below and have been unable to connect.

I am doing a reconfigurator. But does anyone have a suggestion?

best

al


#73

I heard from someone, a reflash of SD card was needed for his bot.


#74

Thanks tim. I did that with no change. I am now downloading 3.1.4 and will flash that img. on the sd and see if that gives me some sort of reset.

Is there a version update on the Mega 2560 that I should be working with?

best

al


#75

Tim; I reinstalled the 3.1.4 sd and did a reconfigurator. I was then able to reconnect through the console to the farmbot. I was able to run my sequences and vacuum pump and the version shown was 3.1.4.

I will monitor the forum and see what is up with 3.1.5.

best

al


#76

Our farmbot is now up and running, tracks are not installed properly yet.
I can now connect to the web app and move the Y and Z axis :slight_smile:

one of the ports on the network were blocked, MQTT ports in our case


#77

I installed 1.3.5, but the computer kept black.Is why?


#78


#79

@RickCarlino


#80

@xiaorong
Can you try this?

  • Make sure you are running the latest FarmBot OS
  • Plug in a USB thumbdrive into FarmBot
  • Wait 20 seconds.
  • Remove the thumbdrive
  • If Farmbot OS is running, you will have a file called logs.txt on your thumb drive now.
  • Send me the contents of logs.txt via private message.