My.Farmbot.io connection issues


#81

Thank you for your response,
Because my farmbot hasn’t been assembled yet, I’m just making some preparations ahead of time.Is that wrong?Should we wait until the farmbot is assembled?


#82

hello.When I open this page (MQTT. Farmbot. IO /), it doesn’t go past, it doesn’t open.


#83

We’re having very similar issues here. I am also at a school. My students built our farmbot this semester. We are running the latest OS (.6) and we actually got the farmbot to connect and moved it a bit this morning. However, now we seem to be back to square one.

FYI: we have been trying to run it connected to both wired and wireless. When it worked this morning, we were connected to both simultaneously AFAIK (or, at any rate, we had the ethernet cable plugged in and we also had put in the password for the wifi network).

Basically, the farmbot configurator network only seems to stay alive for a couple of minutes (or less) so we have to do a lot of re-booting and re-flashing. It’s a bit frustrating.

There could be problems with my network security since I am at a school, but given that it actually worked this morning I am thinking that that is not the problem.

I am about to reboot with a flash drive connected to see if I get a log to check.

Any help would be greatly appreciated. We’d love to see this thing actually working before the school year ends. Thanks for all the hard work making this possible for us.


#84

Following the instructions you gave, I don’t seem to be getting a log.txt file.


#85

I’m sorry.I’m outside now.I’ll try and get it for you.
If you don’t assemble the farmbot, it should have no impact.I want to know whether I should wait for my farmbot to be assembled before I start configuring it.thank you.


#86

@Yellowbeard Sorry to hear about the issues.

@connor Any ideas on why configurator would be cutting out on 3.1.6? It looks like there might be some other issues at play, as logs.txt is not showing either.


#87

For the flash drive trick to work you have to plug the drive in while the bot is running.

Also if it is just randomly rebooting (and when you get to configurator it doesnt tell you why it rebooted) it is almost certainly a bad power issue. Either a bad ground, not enough amps, bad power supply, etc.


#88

The flash drive was plugged in while the pi was loaded with the latest farmbot release and was operational. The problem is, I don’t know if the bot was running (or, at any rate, the bot was not connected to my.farmbot.io).

I don’t know if it’s randomly rebooting. The symptom we’re seeing is that it’s only leaving its wifi connection open for a short period of time. Actually, my guess is that it is /not/ rebooting because, if so, I would think we would see the wifi going on and off at intervals. That’s not what’s happening either. In fact, what tends to happen is that even when we reboot, we often can no longer see the wifi signal (the configurator) coming from the farmbot. We have to then flash the OS again and reboot, at which point we can again see it.

The problem could be with the pi (we did boot into a different pi OS connected to a monitor and were having some trouble getting the wifi working, but that may be because we’re pi novices).

The problem could be with our network (at a school, so things are configured weirdly and I have little control over that but, like I said, we did get it to work at least once, so that seems like it might be fix-able).

The problem could be with the power (we didn’t use the exact one that was specified but one that sure looks like it and claims to have all the same outputs).

Any advice about how to further diag would be welcome. However, having problems like this is ultimately somewhat for the good because it let’s me teach my students learn how to fail forward.

When I try hooking up a monitor and booting the farmbot OS I get no output. However, that seems to be normal? Maybe?

Just having a difficult time diagnosing exactly what the problem is, so any further advice is greatly appreciated.

Thanks for the help thus far!


#89

Wifi has a couple bugs in it right now that stem from some really low level stuff from the Linux Kernel and stuff like that so its possible that could be your issue.
There is also a known feature i just haven’t had time to implement with wifi documented here:

If you have access to a wired connection (via ethernet) that is a good way to test.
note: you can take the pi out of the case and try to get it booted inside say a classroom.

HDMI is completely disabled to save power, bandwidth, and confusion so that is normal.

If you did get it to work once i would say it is one of two problems.

  • power
    • to have reliable wireless networking you will need 5 volts @ at least 3 amps.
  • wifi. Could be one or more of
    • Range
    • latency
    • the above mentioned linux bug.

randomly rebooting is power related, but this doesnt sound like random to me. it sounds more like a latency or range issue.

a large amount of latency causes a factory reset as does the network being out of range.

I suggest picking up one of these for one of these situations. It will be invaluable for any Raspberry Pi project.

Now it doesnt have to be that one in particular, but just make sure it is one that operates at 3.3 volts.

Let me know if you would like to go down that route and i can help you thru setting it up (its pretty easy)

I have another suspicion that i have seen in a couple other cases.
since your bot is not showing the configuration ssid when you boot up, it is getting a valid connection to the backend (over real http) but it cant connect to the mqtt broker. We’ve seen our mqtt broker get blocked in some firewalls. Its possible that it IS connected, you just cant talk to it.

One way ive tested this is configure and let your bot boot up. then on a mobile phone (not connected to a WiFi network) try to log into the farmbot web app.

I know that was a lot of information, let me know if i need to clarify anything.


Re-enable console
#90

We’re actually having much better luck (though I am not sure why) getting connected repeatedly now (although things aren’t stable - we still can’t re-start without flashing and starting over).

The only times we have had success have been when we were plugged into ethernet. We’re using a supernight LED driver for power supply. It certainly looks like it has identical outputs to what was called for. I’ll try to get a multi meter on it and see what the actual output is.

Because we’re hooked up via ethernet I don’t think range is a problem (unless there is some other issue associated with ethernet that might be causing the problem). We have a very high bandwidth connection, so I would have doubts about latency either.

I agree that it’s not randomly re-booting. In fact, it doesn’t /seem/ to be rebooting at all, frankly.

I will try and get the cable you suggest. Thanks for the information. I will try using my cell phone and cellular data connection to see if that helps.

I’m certainly not going to complain about too much information; I really appreciate your time.

I took a screenshot of what things look like when they’re working for what that’s worth.

Thanks!


#91

We’ve now gotten it to work several times. The last time, I had a flash drive plugged in to try and get log and for some reason it got wiped and the information on it was replaced by the following:


#92

@Yellowbeard This WIFI connection is connected to the farmbot right, but I can’t find farmbotWIFI here, but the farmbotWIFI of my phone.I connected to other wi-fi, but when I was done, click ok, the farmbotWIFI didn’t exist.I want you to guide, thank you,


#93

That looks like you accidentally flashed the OS to your flash drive, or you have your SD card open in Windows Explorer


#94

This is by design. FarmBot tries to connect to your WiFi at start-up. If it’s your first time, FB won’t have a WiFi configuration and creates its own WiFi network for you. If it has a WiFi configuration, but can’t find or access the network, it also creates a WiFi network. This network is called “farmbot-” followed by 4 random hexadecimal characters, for example farmbot-0dbf.

Whenever you see this network (on your phone or computer), it means your FarmBot was unable to connect to your home WiFi network. When you don’t see this network anymore, it means one of two things:

  • FarmBot successfully connected to your home network. You will no longer see farmbot-0dbf. Now it’s time to go to http://my.farmbot.io to see if you can control your FarmBot! :grin:
  • FarmBot is stuck in limbo. I think this is a bug, but I’ve had a time where my FarmBot wouldn’t create its own network, but it also didn’t connect to my home network. Solution: flash your SD card and try from the beginning. :rage:

#95

Thank you very much for your reply. My WEB has been connected to the farmbot.


#96

Can you elaborate on this?
You could also Email me or raise an issue on Github.

EDIT: I dont know why it only quoted one word in the post.


#97

@conner I don’t have much to go on, it only happened to me once. Normally the bot boots and I can hear the Arduino power cycling (z is always powered). So that way I could audibly hear the bot rebooting. It does it once when I power the bot, and then again after like 30 seconds when it has found a WiFi config and connects to the network. (I think)

Only that time, it only power cycled once, and then got “stuck” there. It didn’t create its own network but it also didn’t connect to my home network. The bot was unreachable on the web app. Power cycling the whole bot would not fix it. I only fixes it by flashing the OS. I was running 3.1.4 and at that time I needed to upgrade to 3.1.5 anyways. I didn’t report as a bug because since flashing I’ve not had this problem. I’ll keep an eye out for you.


#98

Could you tell me how to solve this?thank you


#99

We’ve seen this before. It usually means your DNS settings are blocking our mqtt broker or redirecting it to somewhere else. Or there is too much latency to establish a connection to our mqtt broker. I would check your DNS settings if you have a broadband/stable internet connection


#100

Errr, I don’t think DNS would have anything to do with the issue you are speaking of. Do you mean “firewall” settings? Most business class firewalls are Layer 7 aware and will block SSL/TLS sessions that don’t carry HTTPS traffic. On the other had most consumer firewalls will allow just about any traffic from inside to outside.