My sequence will not be executed

I built a rather long sequence by my standards. It consists of 70 very simple steps and I called it “new Water-all_plants”.

The sequence actually only consists of 40 different points that are approached and the opening and closing of the water periphery and a few times waiting. That’s all. When I run the sequence, it transfers it correctly, but nothing happens.

How can I start to find the error?

Hi @Kay

Can we “see” your long Sequence ? ( I would like to reproduce the issue you are seeing )

You know that Sequences can be Published by using the latest software (?)

Hi @jsimmonds

It’s my first time “publishing”…

For security reasons, we can’t publish sequences that contain the following content: named_pin, pin_id, pointer_id, write_pin

What can I do?

Oh, I wasn’t aware of those public sharing constraints.

What do you mean “it transfers it correctly” ?

Do you see a Log message “Starting <your sequence name>” ?

Have you tried putting common sequence steps into a new sequence and just calling (executing) it where needed in your “main/big” sequence ? ( i.e. simplifying and reducing the number of steps )

Quick info for anyone who also has the same problem at times, with a sequence not executing.

Here is the solution: I have split my very long sequence with 70 steps in three smaller sequences with about 26 steps each. Then I created a new fourth sequence to call the three smaller sequences. With this workaround everything works fine.

Maybe there is a sequence limit or it is a bug.

Bug(s) I think. If there’s a known Step Limit for any Sequence it should be made clear to the user.
In your initial sequence which included 70 steps, the FarmbotOS would have had a process crash (unreported), which would have looked like the screen capture below, on your IEx Console ( I’m currently using “edit/test/crash” heuristics to determine the upper step number limit in practice :slightly_frowning_face: )

  • edit - 39 steps including 9 MOVE , 18 CONTROL PERIPHERAL, 9 WAIT and 3 other “small” steps will make a process crash and exit ( unhandled exception )

If you have a GitHub account you’re welcome to submit a new Issue based on your post here.
There does seem to be scope for “software product improvement” here :slight_smile:

@Kay I’ve found the bug, tested a solution and will submit a Pull Request tomorrow.
When released, expect FBOS to reliably execute a single Sequence containing > 100 steps.


Thank you for helping troubleshoot and fix this issue @jsimmonds! I just tested your PR using FBOS v15.3.1-rc1 on the beta channel. However, I am still experiencing the issue where the bot silently does nothing when trying to run a sequence with a high number of steps. I am maxing out around 35 to 40 steps as well.

@roryaronson I’ll need to check but I doubt that build has PR#1499 merged in :confused:
because that was the version I based my PR on.

When the fix is released, I’ll re-test with my 107-step Sequence :slightly_smiling_face:

Oh woops! Looks like I had a moment of dyslexia and was testing with the wrong version.

I just tested again with v15.3.2-rc1 on the alpha channel. And… :drum: it works! I tested with a sequence to move a relative distance of 10mm, 100 times. We’ll get this released soon :slight_smile: Thank you so much for another bug fix @jsimmonds! And thank you @Kay for reporting the issue.

100 moves


This fix has now been deployed in FBOS v15.3.2.