New user requests help

I’m trying to set up my new Genesis 1.4. At this point I want to calibrate the axis, but I cannot press the buttons. They are inactive.

I positioned the bot home and zero-ed the axis before calibration, not sure if anything has to do with each over.

Oh, it seems I need to “ENABLE ENDSTOPS” to make this possible. I don’t think I have that, just a physical endstop.

Or “ENABLE ENCODERS” seems to work, I think I have those. Interface says they are default enabled, except they were not. Maybe because the y-axis motor was not connected on first boot?

Glad to see that you found it on your own! :slight_smile:

The helptext of the calibration setting explain whats needed:
If encoders or end-stops are enabled, home axis and determine maximum.

Yeah not not really. I’m getting movement failed errors and write configuration failed errors, and I don’t see how to debug those.

An hour ago it went smooth passed the entire x-axis but failed to calibrate y. Now I’m getting an x-axis movement error.

Movement failed. {:ok, “ok”}
movement_axis_nr_steps_x: “Can’t send command when in :configuration state”

Any suggestions?

Looks like your firmware got stuck somehow when the calibration failed.
You could try to push the RESTART FIRMWARE button in the Device section under POWER AND RESET. If that does not help or generates even more errors you can also powercycle the whole device.

What error came up when the Y-axis was calibrating? Your X-axis was successfully calibrated and the AXIS LENGTH setting was properly filled?

Yes, x-axis value was filled out, just not remembered after the restart. I’ve rebooted the device a few times now.

The x-axis has now movement issues, I don’t know what happened last few hours. It worked before. This video is when I gave it a move command. Two times 100 mm, last try 1000 mm.


Looks like your motors can’t get the full speed that is set in the settings. You could try lowering the speed setting, but as this was working with these settings before you could also check the mechanical settings like belt tension and wheel adjustment.

It would be also helpful if you could post an image of your hardware settings in the WebApp.


  • {
  • “encoder_enabled”: {“x”: 1, “y”: 1, “z”: 1 },
  • “encoder_invert”: {“x”: 0, “y”: 0, “z”: 0 },
  • “encoder_missed_steps_decay”: {“x”: 5, “y”: 5, “z”: 5 },
  • “encoder_missed_steps_max”: {“x”: 5, “y”: 5, “z”: 5 },
  • “encoder_scaling”: {“x”: 5556, “y”: 5556, “z”: 5556 },
  • “encoder_type”: {“x”: 0, “y”: 0, “z”: 0 },
  • “encoder_use_for_pos”: {“x”: 0, “y”: 0, “z”: 0 },
  • “movement_axis_nr_steps”: {“x”: 6542, “y”: 0, “z”: 0 },
  • “movement_enable_endpoints”: {“x”: 0, “y”: 0, “z”: 0 },
  • “movement_home_at_boot”: {“x”: 0, “y”: 0, “z”: 0 },
  • “movement_home_spd”: {“x”: 50, “y”: 50, “z”: 50 },
  • “movement_home_up”: {“x”: 0, “y”: 0, “z”: 1 },
  • “movement_invert_endpoints”: {“x”: 0, “y”: 0, “z”: 0 },
  • “movement_invert_motor”: {“x”: 0, “y”: 0, “z”: 0 },
  • “movement_keep_active”: {“x”: 1, “y”: 1, “z”: 1 },
  • “movement_max_spd”: {“x”: 400, “y”: 400, “z”: 400 },
  • “movement_min_spd”: {“x”: 50, “y”: 50, “z”: 50 },
  • “movement_secondary_motor_invert”: {“x”: 1 },
  • “movement_secondary_motor”: {“x”: 1 },
  • “movement_step_per_mm”: {“x”: 5, “y”: 5, “z”: 25 },
  • “movement_steps_acc_dec”: {“x”: 300, “y”: 300, “z”: 300 },
  • “movement_stop_at_home”: {“x”: 0, “y”: 0, “z”: 0 },
  • “movement_stop_at_max”: {“x”: 0, “y”: 0, “z”: 0 },
  • “movement_timeout”: {“x”: 120, “y”: 120, “z”: 120 },
  • “param_config_ok”: {"": 0 },
  • “param_e_stop_on_mov_err”: {"": 0 },
  • “param_mov_nr_retry”: {"": 3 },
  • “param_use_eeprom”: {"": 1 },
  • “pin_guard_1”: {“active_state”: 1, “pin_nr”: 0, “time_out”: 60 },
  • “pin_guard_2”: {“active_state”: 1, “pin_nr”: 0, “time_out”: 60 },
  • “pin_guard_3”: {“active_state”: 1, “pin_nr”: 0, “time_out”: 60 },
  • “pin_guard_4”: {“active_state”: 1, “pin_nr”: 0, “time_out”: 60 },
  • “pin_guard_5”: {“active_state”: 1, “pin_nr”: 0, “time_out”: 60 },
  • “movement_invert_2_endpoints”: {“x”: 0, “y”: 0, “z”: 0 },
  • “movement_microsteps”: {“x”: 1, “y”: 1, “z”: 1 },
  • “movement_motor_current”: {“x”: 600, “y”: 600, “z”: 600 },
  • “movement_stall_sensitivity”: {“x”: 30, “y”: 30, “z”: 30 }
  • }

Image (hopes this works):

I’ll check the tension in a moment.

Not sure if this yellow voltage mark might be an issue:


Some more testing. All the motors make a little noise when idle. The z-axis motor makes the most sound. See video.

(note the phone was on the z-axis motor housing capturing contact sounds. The sound was easy to hear form a small distance (20 cm). The other motors make a similar sound, just only hearable very very close of my ear on the housing).

When I turn the farmbot off, the sound if gone (of course) and I can move the gantry with little force. Not sure how I can measure if the required force is appropriate, feels “normal” to me.

Booted again. Commanded x-axis move. It moves like the video and on the website this error:

Its most time yellow, and sometimes even red on my device, but everything works fine.

That is quite normal since the setting ALWAYS POWER MOTORS is active. The Z-Axis always has more load since the tool mount is pulling down by gravity.

Did you try lowering the MAX SPEED (MM/S) setting?

If you activate the DEBUG logs on your logs page,
set log levels to max,

you can probably see a log like this after moving the axis.

That means that your encoder did not detect the needed count of steps. There can be a few different reasons for that:

  • Mechanical resistance that causes the motors to need more power
  • Not enough motor power caused by a low motor current.
  • Max encoder reading speed < actual moving speed

So I think that your axis does not move correctly anymore, since you activated the encoders to calibrate. I’d first try to reduce the max moving speed or increase the MAX MISSED STEPS setting.

Found the logs, enabled all, rebooted the system, moved a bit and then started x calibration.

it says error 0, usually that meas no error, right?

Lowering the motor speed seems to help, the x-axis calibaration got half way.

BTW, I’ve reached the max replies for one day. I’ll need to start a new post after this reply.

I think that rather means that error 0 occured. I didn’t find any information what those error numbers mean, but seeing the Firmware debug message: deactivate motor X due to missed steps indicates that there might be a spot where the axis gets stuck. That might be a bad leveling between those two X-axis profile rails.

Just tried calibrating on my device. It was running without throwing that Error writing firmware parameter. You are running on the newest FarmBot OS (V.9.2.0) right?

Btw, I just promoted your trust level in the forums, that should hopefully allow you to post more posts a day. If that did not work, just edit your last post to let me know :slight_smile:

1 Like

I’ll test the connection on the 2 axis bars tomorrow, with daylight. Thanks for the support so far!

Some more testing. All the motors make a little noise when idle. The z-axis motor makes the most sound. See video.

This noise can be turned off when set “Always power motors” to "NO“ , because it is for the motor self-locking

Thanks, will do that. I still think the z-motor makes too much noise when moving, but that’s for a later concern. It has stopped making noise when idle.

I changed the middle of the x-axis a little, moves the farmbot by hand (unpowered motor) and did a new calibration, these are the results of the log (and many debug step count messages of course, left them out):

Can the error be ignored?