No communication to arduino

I recently swapped out my arduino and ramps in an attempt to fix some buggy issues with my farm bot (x axis constantly counting steps, not returning home properly, x2 motor moving inconsistently, etc etc) and I’m now receiving the error message “Failed to execute move_relative: Could not establish communication with arduino: :noproc”

The green light on the arduino is on, and the orange light next to “TX” is blinking. the green light on the ramps shield is usually off, but sometimes turns on and stays constant. I’ve tried swapping USB ports, no luck. I’ve got two ramps shields and two arduinos. IVe used them in every combination possible with no luck

I’m fairy certain everything on the ramps is connected properly. The step drivers are all reading about 1.9 v.

Did you reboot the Raspberry Pi? If the Arduino is unplugged, a reboot is required.

Yes, from the interface I initiated a reboot. I have not re flashed the SD card. Is this what you are suggesting?

OK, So I’ve concluded that my arduinos were both junk. I’ve ordered two more band new 2560’s. They have arrived. I did an ohms test on my stepper drivers and found one that seemed to be junk. Ive replaced that as well. My only concern is the integrity of my ramps shield. Visually, it looks ok but i’m still afraid to plug it in. Do i have anyway of testing that before I hook everything else up and give it a go? I have a new one on the way, but i want to learn more about how to diagnose these. any pointers?

Hey Double_Ewes!

How have you found out that your Arduinos are not working anymore? I guess I have a similar problem as you describe. I also lost the connection between the arduino and the RPi . It is coming bag irregularly.

Best wishes

Hi all, having similar issues from
time to time at the moment. Tried to restart the bot, refresh the page and somehow it then disappeared. I couldn’t find any “logic” behind but I definitely only have it since 5.0.1 or 5.0.2…

@Joberk Have you tried plugging the arduino into a computer? I simply connected them to my Mac and Pc via USB. Both computers did not recognize them. I went down the rabbit hole of uninstalling the apple native driver, installing the arduino driver, even running a custom script I found online to search for the driver etc etc and didn’t have any luck. I borrowed a new arduino from a friend and plugged it in, it appeared in my device manager right away. that’s how i knew the old ones were sand.

1 Like

@klimbim all of my issues started before 5.0.1 and once my issues started they never resolved. It sounds like we might be experiencing different problems, best of luck!

Hey, I solved my issue by testing the encoder cables. Does your problem still occur when all encoder cables are unplugged?