Raspberry Pi 3 not connecting to Farmduino

Hi everyone,
I’m having trouble connecting the Raspberry Pi to the Farmduino. After successfully setting up the network, it’s showing the code 30 error.

I tried clicking the buttons corresponding to flashing and restarting the Farmduino firmware respectively, but that is also returning an error. I tired manually flashing the firmware using the Arduino IDE , but a time out error occurs while uploading the script to the Farmduino.
I tried following the steps given in the website to resolve the code 30 error, but to no avail.
I would really appreciate if someone could help me out on this.

Thanks in advance!


Welcome !

How did you go with the recommendations in the Diagnosis panel ?

( i.e. verify I/O cables, FIRMWARE selection in the Web App, etc., etc. )

Hi @jsimmonds

Thanks for the reply.

So I have tried restarting the firmware, verifying the I/O cables, flashing the firmware as well even tried uploading the firmware from Arduino IDE but no luck.

But later on, we had another Farmbot running and we swapped the Farmduino and it worked like charm and tried that Farmduino on another Farmbot it didn’t work.

Hi @DAA ,

Some customers have reported this problem in FBOS <= 13.

My recommendation is that you upgrade to version 14. Even though it is still in “beta”, it is stable enough for daily use now.

Please let me know if upgrading to v14 helps. I attempted to upgrade your device remotely, but it appears to be offline.

Sure, I will try upgrading to v14.

One more thing, FarmBot doesn’t connect to the setup or configurator with that Farmduino but works with another Farmdunio and keeps showing this error: " Farmbot_ext exited 5: : shutdown "

Please try upgrading remotely, now it is online



Thanks, it is connected now!

No problem, @DAA

I fixed the problem by upgrading your device to v14.

I don’t know what the problem was, but it was probably a software bug that we fixed in v14.

I’m glad to see you are running again! Please let us know if you require further assistance.

Hi @RickCarlino

It seems to be disconnected again

but it has Success: Firmware flashed. MD5: 4F1031EB193

@DAA I am so sorry- it appears you have found a bug in FBOS v14 that is unrelated to your original issue. Thank you for reporting this- I will fix it and publish FBOS v14.0.1 shortly.

I have temporarily fixed your device, but unfortunately, until v14.0.1 is released, the problem will return when you reboot. You can temporarily work around the problem by leaving your device running (firmware currently works).

This problem is my top priority today and I hope to have a permanent fix soon.

@DAA The problem is now fixed and you can safely turn your device off.

Again, we apologize for the inconvenience and thank you for bringing the issue to our attention.

Please let us know if you need anything else and have a great day.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.