Self hosting setup error

Context: I’m trying to use the web app part of FarmBot for another project and I don’t have a physical farmbot device. I was trying to see how it works first, but I get stuck at the setup.

The error I have is the same as here

I’ve followed the setup from the on github but can’t seem to figure out what ip to use for the MQTT_HOST and API_HOST in my .env file.

Do I need to have a physical device for it to work? or is there a way to bypass this by using a fictive address?

Whatever the adresses I use, the web page is stuck on this ‘loading’ state, and I get this error looping indefinitely (even after the build is complete).

Thanks for reading! :smiley:

Caveat : I’ve never attempted Web App self-hosting :slight_smile:

The first error in your screen capture suggests that no “server” process is listening on endpoint . . I’d re-check all relevant configuration settings.

MQTT_HOST and API_HOST should be the local IP address of your device that runs the web-app.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.