Unable to Configure Farmbot - urgent


#1

Hi,

I have sent several emails but have not received a reply so I’ll give it a shot here.

I had a problem where the farmduino board stopped working. It lost all power and was pretty much dead. I plugged a raspberry pi power supply in and I had lights on the pi. I had my bot working properly for a couple of hours. Farmbot quickly sent me a replacement Farmduino 1.4 and I installed it.

I went through the configuration process that had worked for me originally. The raspberry pi had all the right lights etc but when I ran the configurator, the firmware flashed across to the farmduino but halfway through, the farmduino reset. There was an audible click, the lights stopped flashing quickly on the farmduino and the transfer stopped. The configurator went to the credentials page and reset the raspberry pi. I then had the flashing blue configure light.

I have:

  1. ensured the port is open to the internet. the ethernet port is totally unrestricted and I have tested it with several computers. it was working just fine with the exact same setup.
  2. used wifi instead
  3. used 5 different SD cards with all different versions of the farmbot os, all prepared with balena etcher.
  4. used the arduino IDE to put the firmware on the farmduino.
  5. replaced the power supply to ensure the power wasn’t dropping and causing the farmduino to reset.
  6. had the whole system tested by an electrician - the power point and power supply are correct.
  7. Replaced the raspberry pi and tried all of the different SD cards on that.
  8. Powered the raspberry pi with a raspberry pi adapter as well as the power from the farmduino.
  9. Changed the login and credentials for the bot.
  10. Created another farmbot account.
  11. Tested the old farmduino board - still as dead as it was before.

I have spent over 100 hours getting my farmbot going and I need it for my students. I am at a complete loss as to why it is not working. It is a very expensive piece of machinery that my bosses wanted working this week and at the moment, I have no answers for them. I have run the configuration process at least 50 times so I’m a bit frustrated with it. I have a team of IT guys available to help me but they haven’t been able to work it out either.

I am located in Hurstville, Sydney, Australia. If there is anybody that can point me in the right direction, local or otherwise, I’d be most grateful.

Thanks,
Mark Gregory
Danebank Anglican School for Girls


#2

Adding the Gurus…
@roryaronson
@RickCarlino
@Gabriel

It sounds like you have done much…
Have you tried going “bare bones”?
(Disconnect as much as possible - all motors, pumps, peripherals)


#3

@markgregory8,

Thanks for reaching out to us. Can you send me the email address of your FarmBot account(s) over this private message so that I can see the logs that were generated prior to the crash? @connor and @Gabriel (who typically handle electrical / FarmBot OS issues) will be in the shop in a few hours to review your issues.


#4

This sounds like normal behavior to me. The “the firmware flashed across to the farmduino but halfway through, the farmduino reset” can sometimes look like a problem happened because the progress bar is actually just a hoax. The progress bar is on a timer and has no actual correspondence to the process of sending data to the Farmduino. Some browsers just get the timing wrong somehow. I will work on a fix for this to make the progress bar more useful.

Did you continue and finish configurator before the reset?

  1. What verison are you using? If it’s not version 7, please try it. V7 was released pretty recently and has quite a few fixes for networking support along with support for WPA-EAP networks.
  2. What sort of network are you using? Ethernet, Open WiFi? WPA? EAP? What are the IP settings?
  3. What was the error code? there should be a screen that says something like “please screenshot or copy paste this message, and send it to the Farmbot developers” when Configurator boots.

I’ve found that issues getting Farmbot connected (especially in schools/protected networks) is related to this. The most common culprit is by far allowing access to pool.ntp.org for time synchronization. I have a sneaking suspicion that your problem is related to NTP access as it is by far the most common issue and your description of

Really matches the description of NTP not working correctly.

WiFi will just add extra complexity, so if you have access to Ethernet, i suggest keeping it. That said as a test, can you please try using a phone’s wifi hotspot feature if you can? This is a good way to tell if it’s an issue with Farmbot, or an issue with network settings.

If you get to configurator, the SD card is almost certainly not the problem.

Farmbot reflashes the firmware on configuration anyway, so this probably won’t help.

I’ve found that power delivery to the Raspberry pi can be tricky, but if you’ve booted to configurator, power probably isn’t the issue either.

Again related to #3, if you’ve booted to configurator, the rpi/sdcard combo are almost certainly in good working order.


#5

Hi Guys,

Thanks for your reply!

I will respond to Rick directly.

I ran the configurator today and this is what the screen looked like after the first failure.

I used Version 7.0.0.

I have tried both ethernet and open wifi with a 4g wifi dongle and with a personal hotspot on a phone while using a PC to do the configuration. I have entered the credentials with both my original farmbot account and the new one that I created.

I spoke to our IT guys and they gave me a bit better detail about what it is doing.

When it is configured, it is set to ethernet and dhcp. It is farmduino V1.4. It is then assigned an IP address by our system and the guys are able to see it do that but then, for some reason, they can’t ping it. It is not even connecting to the system let alone the internet, despite the port being totally open and a few different devices connected using the same cable can be pinged.

We are able to ping pool.ntp.org on a pc connected to the port.

When I say it worked for 2 hours, I had it working for a couple of days but only used it for about 30 mins on one day and a bit longer on the other. I ran a program that made the machine collide with another part of the machine and when I went back to it, there were no lights on anywhere. Rory sent me a new farmduino and now I have all the lights on that I should have but cannot get it to configure.

I have noticed that on my farmbot device account on the web interface, it still says that it is moving to …

I did try to create another account to get around that but I am wondering if that has anything to do with it?

The only thing I didn’t do today was disconnect all the motors, encoders and peripherals as suggested by one of you guys. It was 39 degrees C in Sydney today and I was short of time so I didn’t get a chance to try that.

Thanks for your time. I really appreciate it!

Regards,
Mark


#6

Hi Rick,

Thanks for your reply!

I have tried 2 different accounts.

The one that I was using when the machine went bust was:

mark.gregory@danebank.nsw.edu.au

The other one I tried was markgregory8@gmail.com

Thanks again!

Regards,
Mark

Edit Note: Account credentials removed. Passwords are usually not needed. Also it would be much safer to send this kind of information in private messages directly to RickCarlino.


#7

Alright so my assumption was correct that ntp was failing. This propagates in an SSL/TLS issue, because validating those certs requires an accurate clock, which due to failed NTP your device does not have. I will investigate more and let you know why it is happening.


#8

Thanks Connor. That would be great!

I spoke to our IT guys again today and they think one possibility could be that after the configuration, it reboots, gets an IP address through DHCP then by the time they try to ping it, the raspberry pi has already reset to default again and is back ready to be configured. The SSL / clock issue would explain that behaviour but they were unable to pinpoint the reason for it.

The fact that I’ve previously had it working on the same port / cable / network and we can reach the ntp server from a computer seems strange to me but I am no expert!

Thanks again for your time. I appreciate it!

Regards,
Mark


#9

@markgregory8

Did you have any luck debugging the clock issue?


#10

Hi rick,

I was waiting on Connor to check it out for me. I have exhausted all possible leads at my end. I’ll be doing backflips if it gets fixed!

When I go into my farmbot, it is stuck trying to move. I don’t know if that has anything to do with it but I thought I’d mention it anyway.

Thanks
Mark


#11

Hi Guys,

I just tried the bare bones approach with everything disconnected except the raspberry pi and the farmduino. Still getting the {tls_alert, ‘record overflow’} error. Also tried it again on my phone hotspot. The error was different but I didn’t screenshot it. Something about the network not being connected after one minute and there were possible reasons like being out of wifi range, hardware issues etc. It is possible that my phone hotspot was no good as service is not particularly good in that area but I am confident that if it had of connected, it would have given me the same tls alert error message that it has given me previously.

I am hoping you guys can track down the problem. Have some rather anxious teachers who have based a whole unit around the farmbot.

Thanks,
Mark


#12

Can you post the error from the phone hotspot? the tls_alert indicates your device is unable to set time from NTP. If your bot could connect to your mobile hot spot, it should not give you the same error.


#13

Hi Connor,

Here is the screenshot that I get when trying to connect to my phone.

Thanks,
Mark


#14

I had problems when I did a mobile hotspot, too. I was able to get connected to the web app and even do some basic tests (move the bot), but every now and again it would reset the configuration. I think mobile hotspots are flaky in general, and on e dropped I think FB reverts to the configuration screen…


#15

Hi Guys,

I thought I would try a different approach and connect a normal Raspberry Pi with the standard operating system to the Ethernet cable attached to my farmbot.

I first set it up in my office and I was able to ping pool.ntp.org successfully. I then took it out to my farmbot and was also able to ping it there but the two IP addresses were totally different.

I just want to check with you to make sure that the following address in the screenshot is the one it should be trying to access ( I had to photoshop it as it is in full sun there). The .static.tpgi.com.au is something that wasn’t on it when I tried in my office and the numbers are totally different as well.

The network switch is located in a house that my school acquired and whilst the IT guys don’t think its any different, they are somewhat confused as to why the address would be so different.

Don’t know why this would be an issue as my farmbot was working previously on the same ethernet cable / port but who knows, there could be something in it.

Thanks,
Mark


#16

That is a little weird. I suspect the different IP addresses are a normal thing since NTP is made to be pooled. IE depending on load, you might get a different IP at different times. There’s also an issue with Farmbot itself in that getting NTP is sort of a race. NTP protocol doesn’t support errors or timeouts so Farmbot has to make some “gueses” as to if time has been set or not. I might be able to make a couple changes to make this easier. I’ve seen this issue come from several folks living in Australia so i think maybe the NTP pool is just a slow connection.


#17

Hi Connor,

Thanks for your reply.

Is there a way to see what the farmbot is doing while it’s booting up i.e seeing what IP it’s trying to get to etc?

If I hook up a monitor to the hdmi out on the raspberry pi, will I see anything? Does farmbot create any logs of its activity if it’s not connected to the internet?

As you can probably tell, I’m pulling out all the stops to get this thing going!

Thanks,
Mark


#18

Hi Connor,

I just went and tried to run the configurator again, entering our own school ntp server in the field for the ntp server 1 and 2.

I also tried it with the google time server - ntp.google.com in both 1 and 2.

I tried the combinations of both. I was able to ping both of these time servers from the same ethernet cable as the farmbot is connected to.

Neither of those methods worked :frowning:

Still giving the tls_alert record overflow error message upon restart.

Hope this gives you more information to work with.

Thanks,
Mark


#19

Hi connor,

I also hooked up a screen to the raspberry pi and tried a number of different methods - raspberry pi only, raspberry pi and farmduino only, raspberry pi with farmduino and camera.

I video taped the screen as best as I could. If that will help you, I can get the videos to you.

Here’s a screenshot.

Sorry to bombard you with information but I need this working ASAP.

Thanks,
Mark


#20

I had a similar issue. However, it got resolved when I used my personal hotspot or an ethernet wire without any restrictions.