Vacuum pump power

Hi everybody, is anyone having problem with the vaccum pump? Does your seeder tool easily pick the seeds?
We can’t make it work. it seems that the nozzle has not power enough to pick any seed… we’re wondering if it’s a matter of lick of vacuum al along the line, or through the seeder tool connection.

I had this problem also for a while until I made some modifications to the FarmBot itself. I just moved my vacuum pump to the main bracket of the Y/Z axis

It’s also noted by Rory that the newer FB kits have an updated design for the vacuum pump where they shortened the length of hose between the pump and the tool head. this allows for a greater level of suction and a more consistent and higher successful seed pick up rate.

Ill upload some photos of my mods here in a second.



hope this helps!


Thank you! Cjaramillogrows, I think we’ll try the improvement you suggested.
I just wonder if is that ok for the outdoor use we’re doing… will the pump, out of the plastic waterproof box, resist to rain in that position?

No problem!

Hmm :thinking: so that is something of a concern for you. Our FB is an indoor educational unit so our case is a bit different but I would suggest trying to figure out some way to cover the vacuum pump, you don’t want the +/- contacts to get wet or the inside of the vacuum.

look at the motor housing covers for the X and Y axis - something like that would be more suitable as it allows for the motor to be able to have protection from the rain and is open enough that it can give off heat ( if using it for a while) and have adequate suction from the intake opening.

You can even go pick up a little bit of acrylic or plexiglass from local hardware store and cut out pieces for the housing and epoxy them together yourself.

best of luck! :thumbsup:


As @Cjaramillogrows mentioned, with the v1.3 design we have moved the vacuum pump closer to the UTM (mounted on the z-axis) and shortened the tube to about 0.4m so that there is greater suction at the needle.

For v1.2, make sure that there are no kinks or pressure spots on the tubing where it is entering and exiting the various cable carriers. That can significantly restrict airflow and cause poor results.

We’ll have some v1.3 vacuum mounting plates and plastic housings available for sale when we open our full online shop, though that unfortunately seems to keep getting pushed back due to delays. In the meantime, you could machine/3D print parts if you are capable of that, or DIY something together from hardware store materials as suggested.


Ok, I think I’ll do something in this way, building a small case for the vacuum, thank you!

1 Like

Thank you Rory,
I’ve already made a test removing the waterproof box cover because it actually makes a little pressure on the tube, but no results! I’m going to make a deeper check on the various cable carriers first but I think I will move the vacuum pump in the new suggested position

1 Like

Good luck @Basto! message me or reply to this thread if you need any more help.

1 Like

grazie! I will!

1 Like


1 Like

Ok, we’ve moved the vacuum pump in the suggested position but still not powerful enough to pick seeds up… I wonder if the pump is not working properly. I’ve also tried to feel with my thumb under the nozzle but the vacuum seems a bit wick for the pourpose… do you know how could we check if the pump works good?
Thank you!
Basto & Luigi

I’d put a short piece of tube on the pump and check the vacuum at the end of that tube. If its not very strong, its your pump. If its good, then make sure your connections at the tool side of things are good.

This is a fairly simple way to mount the vacuum pump to the z-axis as close to the uni tool mount as possible. Note I am using the FarmBot indoors so don’t have to cover the pump. The weight doesn’t seem to affect the z-axis. Sorry should have added it to this thread instead of starting another.

I noticed even though the pump is ~10cms away from the seeder nozzle there wasn’t a massive increase of vacuum pressure. I think this is because the nozzle hole is so small or the pump needs to be more powerful. I have thought of a possibly better design I might try out.

Basto for me the nozzle (the smallest black one) needs to be 1mm from the seed to pick the seed up.

1 Like

Ok thank you! I’ll make a test with the shortest pipe lenght to evaluate the real power of the pump. I thought too that there could be some leak in the junction between the tool mount and the seeder mount itself…

1 Like

Those pumps are cheap on ebay, amazon or ali express so if your still having issues I’d get a new pump.

Even after my mods to the vacuum pump i still dont have a 100% successful pick up rate without having to manually press the tool head onto the tool mount after picking up a tool.

I have to squeeze the two together and that gives me the proper seal needed for a 100% success rate but at the cost of manually interfering. Ive also tried to compensate by having the FB press down an additional 2-3 mm onto the tool head (when mounting a tool in the tool bay) in an attempt to give it that “extra press” to properly create the seal but its hit and miss.

Im going to try and wrap some sealant tape (used when connecting water pipes with threading) around the male end on the UTM with the hopes that it will be enough to create that seal im looking for!

That really sounds like a problem with your magnets not working properly between the uni mount and the tool, I would look at that. I don’t have that problem in fact I was picking up too many seeds, so had to switch to a smaller needle. I wouldn’t press the FB down onto the tool bay that might over time burn out the stepper motors. You shouldn’t have to use sealant, check why the magnets aren’t sealing the tool to the tool mount there may be a screw that is too far out preventing them from coming close together.

1 Like

very good point!

Im going to check out the magnets and the screws to make sure everything is properly set. I do remember when i first set my seed sequence up my FB would also pick up 3-4 seeds and after a little while i was having the issue with not a strong enough amount of suction to properly grab the seed.

thanks @whitecaps

Also check where the end of the air hose fits over the nozzle inside the UTM. I have a small zip tie around that.

1 Like