Wifi configurator issue ("certificate expired")


#1

Hi all,

I had a problem with the farmbot not getting connected to my user after the latest firmware update. I followed these steps:

  1. Turn on the farmbot
  2. Access the farmbot wifi
  3. Configure everything
  4. Waited and saw that farmbot wifi was available again
  5. Repeated procedure and nothing worked

I got this error message “certificate expired” and tried to reflash the latest farmbot OS into the SD card as it is suggested in this post.

After flashing the OS into my SD and putting it into my raspberry pi3, I start the raspberry and get no WIFI configurator enabled (no farmbot-XXX wifi network is available).

Do I need to plug the arduino mega with the RAMPS in order to get the wifi network available?

I would appreciate any kind of help!


#2

The FarmBot WiFi network should show up without an Arduino connected. If the pi LEDs aren’t functioning normally, it’s possible that the SD card flash wasn’t successful. As mentioned in the other post, the original issue is likely with NTP.

Which FarmBot OS version are you using, and which method are you using to flash it to the SD card?


#3

Hi Gabriel,

I was using the latest release available (“farmbot-rpi-7.0.0”) and balenaEtcher to flash the SD card. I was really just following your guide :slight_smile:

Regarding the LEDs, the red LED is always on and the green one flashes.


#4

Hi all,

After several failed tries (I tried to flash the SD with a windows and a mac PC), I decided to change the Raspberry pi for a different one and, to my surprise, it worked!

I should have tested this before putting the post. However, thanks a lot for your help!