Working motor / encoder settings changed?


approximately since mid july this year, I started to have various problems with fb movements, missed steps etc. I had my device settings adjusted for tmc2208 / 1/2 microstepping.

I have posted device settings that worked for me until that time to this thread

However today I managed to resolve all my movement issues (missed steps, farmbot would move 20cm instead of 10, or it moved 10cm, but adjusted its “kniwn” position to 5cm etc) - the only problem is that it only works with settings that are not inline with documentation & form validations in webapp/ device page. In fact this was just trial / error process and I have no idea why this works now. Was there some SW update that changed the way device settings control movements?

below is pic with comparison of the 2 settings:

PS: I have stock farmbot v1.4 / FB os7.0.1, use TMC2208 drivers for X and Y axes, right now default driver for z Axis (hence I did not include Z axis into the comparison…)