X2 is doing nothing (connected to E0 on RAMPS)

According to genesis.farmbot.io, I don’t have to connect the X2 motor’s encoder cables (only X1).

But in my setup, the X2 motor is doing nothing, which causes the gantry to torque unless moving really slowly (max 150 steps/s). While moving along X, only the motor above the electronics box is working, and the rest just gets dragged along.

I have already unpowered, swapped the power cables of X1 and X2 and powered back up. This time, only X2 was moving.

I’m 100% sure I have connected those 4 stepper drivers correctly onto the RAMPS, with those little screws above the heat sinks.

I’m not too electronics savvy, but should I rotate those screws or something? I’ve left them untouched, and assembled them as they came out of the box.

Doing it like this, all other motors seems to work perfectly fine.

Are you sure I don’t have to connect the encoder cable for X2? It’s plugged into the motor, but not plugged into the RAMPS shield. Should I unplug it from the motor as well?

The encoder for the X2 motor is not used by the software.

The stepper driver screw is the power limiter. Often the motor doesn’t have enough power and the screw needs adjustment. At the pololu.com website is a tutorial to do that according to spec. Or you fiddle with the screw some until it works.

Could you let me know how I safely “fiddle” with it? I’d rather do this with great care because I don’t really know what I’m doing.

Is there a way I can troubleshoot these components? Does the RAMPS shield provide logs somewhere?

It’d be great if in the web app you could upload your logs. That would help you guys as well.

1 Like

RAMPS doesn’t provide any log. This is all in the electronics without feedback. Systems that do give feedback or don’t need that calibration exist of course, but are at least an order of magnitude more expensive.

The exact procedure from the manufacturer:

The video on that page is very concise, even for a n00b like me. Still, electronics isn’t really my cup of tea.

Would it be too much to ask you guys to add some hints to your assembly documentation for what to set the “v-ref” on the drivers to? I just bought the FarmBot pre-order package and didn’t really care which specific model of motors I’d get, I just wanted something that “works out of the box” from you guys.

So, considering the fact you know exactly which motors I have, you could tell me what to set this “v-ref” to on the stepper drivers. It’d be great to add this to your documentation as well. I understand not everyone will be using your pre-packaged FarmBot kits, but you have to consider that those people who bought those kits are a little less savvy than people who have been doing everything themselves.

I just want to program and plant things, I don’t want to calculate voltage and amps and fry my electronics.

plz halp

1 Like

LDO-42STH47-1684BC (official motor).pdf (143.2 KB)

2.6 VDC, 1.68 A I read in the specs. That’s the extend of my knowledge.

@roryaronson can you help?

Okay, so I probed my drivers with a multimeter. I probed X, Y and Z drivers and they are all set to about 600 mV. These drivers are working. Then I probed the E0 driver, and it also read out 600 mV, but the motor connected to this driver does not do anything.

I have already ruled out the motor itself (by swapping the motor power cables between E0 and X). When I do this, the X2 motor does work and the X1 doesn’t. That rules out a motor malfunction.

So what else could be the problem?

There is a setting in the hardware widget on the device page of the web app for enabling the second x-axis motor, which I assume is enabled in your case. Can you try disabling it and then enabling it again to rule out the setting as an issue?

You can also try swapping stepper motor drivers.

Not sure what’s up. I tried that yesterday (seemed like a plausible cause) but it didn’t fix it. But now it did. That’s pretty weird!

One peculiar thing is, though: The X1 and X2 power cables are both connected with the yellow wire on top. But in the web app, both motors are set to go the same way (Invert Motor is OFF on both). Yet according to your assembly documentation, you’re supposed to reverse the order on the X2 motor power cable.

Okay, so we’ve gone from doing nothing to not keeping up. It seems like the X1 motor is slightly faster.

I’ve tried to

  • Adjust belt tension
  • Equalize gantry
  • Loosen all eccentric spacers to loosest setting
  • Position gantry in middle of tracks, lift the FarmBot up, so that both tracks come off the ground, thereby releasing them from any tension or misalignment they might have had.

But no matter what I do, X2 is slower than X1. This causes the gantry to twist when traveling bigger distances. There is a lot of backlash when the gantry reaches destination, as both motors become unpowered, X2 lashes forward about 5 cm (traveled for 80 cm).

I’m traveling at 300 steps/s with acceleration at 1000 steps. This seems to cause X1 to spasm a bit when it starts decelerating. Any faster settings than this just makes every spasm more.

150 steps/s seems like a failsafe way. X2 still lags behind but the whole thing is quite steady. Still backlash of course.

What can I do to make X1 and X2 step equally fast?

1 Like

Where X1 could easily pull the whole gantry by itself, it looks like X2 isn’t capable of that. As if it’s less powerful than X1.

I’ve unplugged X1 to test this. Also, I’ve tried the documented version of the power cables, but that just makes the motors try to go in opposite directions… Your documentation seems to be backward about how my motors are behaving.

Here is a video of my X1 and X2.

X1 turns smoothly but X2 just jitters around. Even with no load on the motor it does this (I took the belt off so you can see it better in the video).

I assume you bought the kit from the website.
Did you try to swap X1 and X2 Motor connections at Ramps, so you can see if this behavior changes?

Cant imagine that there are many ways to change motor speed hardware wise. If the motor current would be too low you could see or hear the motor getting stuck for a second. -> As seen in video it barely moves :frowning:
Since you are using the official kit, I’m pretty sure there are no jumpers under your drivers which would change the step size.

Just seeing your video while writing. There is something wrong for sure. Had a similar behavior recently when I accidentally switched two motor cables when crimping the dupont connection. But I guess you are using everything out of the box right? Looks like its Hardware related …

Yes, I’m using the v1.2 Genesis pre-order kit.

Also, I’ve flipped the power cables for X2 to reverse the order of the colored wires. X1 = Yellow on top, X2 = black on top, but that doesn’t seem to help (and it seems like X2 is more trying to push to the opposite direction when I connect it like that).

I’ve also tried numerous speed settings. Y and Z are behaving very well, X is a problem child (twinz… amirte!? :expressionless:). Settings X axis to default speed and acceleration (800 / 500) just makes the whole gantry lock up when it’s at top speed. It only moves during acceleration and deceleration when the speeds get slower.

Please tell me what kind of video footage you need to help me troubleshoot this.

Just to confirm, I have a bag of jumpers but none of them are connected to the RAMPS board.

1 Like

Swap Drivers and make sure that your Ramps shield is properly connected to arduino. I believe this might be a bad connection somewhere that only affects your E0 output.

I wonder how your gantry is even moving with such a blocking X2.

It seems that once the X1 pulls the gantry into a certain directly, X2 comes out of its limbo. But even when it tags along, it has already caused the gantry to become un-equalized.

I’ve powered down and firmly pressed the RAMPS shield onto the Arduino underneath. Powered back up, nothing changed.

Then, before taking out the drivers and swapping them, I figured I’d try to swap the power cables once more (X1 motor on E0, and X2 motor on X).

I think I can now confirm that it’s the driver, because now X1 is jittering and X2 is trying to pull the gantry on its own.

So, if we narrowed it down to the stepper driver, but I already confirmed that the VDC in both X and E0 drivers is 600 milliVolts, what else can I do to troubleshoot this stepper? What else can I configure to stop it jittering my motors?

Or is it just fried? :cry:

Take the driver to another axis (like Y). Then check if the motor also struggles on this axis.
In almost a year with 2 Farmbots ive never damaged any drivers (A4988 and drv8825) so far. But if there was production failure in this we cant do much :unamused:

I also had this issue a few times when Farmbot was settled into garden. Most time the unplug/plug of Ramps and Drivers did it. Thats why I assumed a bad connection between those parts.

It’s getting late. I will swap E0 with Y driver tomorrow or Wednesday, and then we’ll take it from there. Thanks for all the support so far, guys.