X2 is doing nothing (connected to E0 on RAMPS)

IMO 600mV is insufficient for the stepper motor, should be more like 1V. The actual value depends on the motor load, which of course will vary between individual machine builds, and could easily be different between X1 and X2. Try rotating the Vref clockwise to increase the voltage a bit.

A bad connection is also possible, the connectors are fine for prototyping, but totally inadequate in a vibration environment. I plan to re-do my electronics soon, replacing the connectors with more suitable types.

1 Like

And this value is based on what?

Itrip = Vref / (8xRs)
Rs is 0.1R, so with Vref at 0.6V, Itrip is 0.75A. This is reduced to 0.525A by the A4988 chip for full step operation. The motors are rated at 1.7A, which equates to a Vref of 1.36V (actually 1.9V when you allow for the full step current compensation by the A4988). So you have plenty of room to increase the Vref. The tradeoff with increasing Vref is the extra current means the A4988 will get hotter, not really a problem until you get up to say 1.5A. So my recommendation is to set the Vref to 1V and see how that works (I’ve set mine to 1V, a bit more on the X axes).
The only one you want to be careful of is the Z axis which is always on, so you’d want to increase that one slowly until it works satisfactorily. Unfortunately there is no way with the RAMPS board to wind back the holding current, which would be the preferred way of controlling the steppers when idle.

2 Likes

I know absolutely nothing about electronics, but I do like to reason critically until it makes sense to me.

In the video linked by @Tim [quote=“Tim, post:4, topic:1815”]
The exact procedure from the manufacturer:

Pololu - Video: Setting the Current Limit on Pololu Stepper Motor Driver…
[/quote]

I think she mentions that there are two coils in the stepper motor.

So doesn’t that mean it has 0.525A per coil? So just above 1 Ampère for the motor? Sorry, don’t want to turn this thread into “let’s teach Marc basic electronics”, just want to avoid tuning things I take for granted because “it’s on the Internet”.

Yes there are two coils in the stepper motor, the A4988 has two ‘coil’ drivers, and Vref is applied by the A4988 to each coil, so we’re only ever talking about a coil. The motor is specified at 1.68A per coil (not per motor).

2 Likes

Hey @Loveny
thanks for making this clear. It’s great having someone here that knows how to adjust the drivers.

This could become tricky, I think those drivers are usually shipped with 0,6V. Means that some more users will need to adjust those, so we should think about writing a guide or add it to the docs @Gabriel @roryaronson ?

2 Likes

Yes!

I’ve swapped the E0 driver with the Y driver. X1 and X2 now perform flawlessly. Y-Axis now does not move at all (not even jittering).

So I increased Vref

I’ve set the Y driver to 1026 mV. It still won’t move a single step.

I think it’s fried…

On farmos 3.1.5, I have all the motors moving except for x2. I can hear and feel that it is trying to move, but it just does not. If I ‘help’ it a little, it makes jumpy movements, but barely turns.

In addition, I can feel the heat sink of the stepper driver (E0) of that motor getting significantly warmer (hot!) than the other motors.

I’m quite sure that I’ve assembled the arduino in general and the controllers in particular correctly.

As suggested in this thread, I’ve swapped the E0 driver with that of another motor (Z). When I do that, both x motors are spinning like the earth around the sun, but Z is not moving.

Seems fried?

I have not yet tried to play around with the voltage of the driver…

@creimers you describe the exact same problem I had, indeed. Coincidence?

@mdingena Have you tried replacing the fried unit?

I only have the four drivers included in the farmbot kit. I’ve tried to contact the team about their return / replace policy but haven’t heard from them yet.

I did swap them between Y and E0, and the problem moved with the driver, so it really is isolated to the driver.

It sounds like there may be issues with the drivers. @mdingena and @creimers I will contact you both privately regarding replacements.

1 Like

I replaced the faulty driver, now all motors are working! X1 and X2 both drive the gantry and it doesn’t twist anymore :smile:

Thanks for troubleshooting with me.

2 Likes