Y axis off the chart

Hi, see screen shot, i had no issues with Y axis movement till i tried to take a photo, the Y Axis then tried to move outsite the defined area and the motor kept running kill i e stopped. How is this possible when i have enabled stop at home, the motor keeps going and has moved the virtual head out into space. Any thoughts or ideas welcome

@Jack Can you perform a FIND HOME operation and try to reproduce this issue? Though there isn’t enough information to say for sure, it seems that your device may have lost its step count. Running FIND HOME on all axes may fix the problem. Please let me know if it doesn’t though and I can investigate the matter further.

I i tried find home and the Y axis just kept running the motor and moving the graphic further away down the page, had to e stop, so i then turned off and on, that reset things, but now trying to re run my sequences now getting errors about problem running rpc command no match of right hand side value.

@Jack I will remotely inspect your device now. You may see the device move while I inspect your configuration.

I was just able to get my FB back to life before it started raining again (as it does since weeks…). While I tried to find Home I experienced the same issue on all axes. The motors just keep running and running. First I thought that the timing belts are too loose on my X-axis. But it also happend after tightening and on all other axis even the Z-axis.

@masze If you are interested, we have published FBOS v14.0.0 beta with a fully re-written firmware handler and updated Farmduino firmware. It’s nearly stable aside from a few of the issues noted in the link (most related to Express models).

If you are OK with the few remaining issues that we’ve noted, I would be interested to see if v14 helps solve some of the issues you are seeing.

Again, v14 is nearing publication, but it is still in the “beta” phase- bug reports are appreciated.

1 Like

I could give it a try. When is it expected to get stable?

Please bare with me. The weather forecast is again quite rainy and I can only work on the FB in the evenings while I’m also on my workplace emergency response this week. So I can’t guarantee that will be able to do some tests but I expect that it will be possible. :slightly_smiling_face:

If you’re using Genesis, it’s probably stable enough today. Estimates for these sorts of things are difficult to give since bug hunting is a research task. Probably a week or two at this point, assuming no new issues arise.

1 Like

@Jack Are you still having the problem? After testing things with your device, it seems like a simple case of needing to tune the Y-axis motors (possibly by increasing motor current and max missed steps).

I was able to reproduce the “No match on left side of value” error you mention, but that was just a motor stall that needs to be fixed by tuning motor settings (or clicking the “RESET PARAMETERS” button and starting fresh).

I was not able to reproduce the camera issue - are you able to reproduce that issue locally still?

Things I changed while investigating:

  • Increased MAX MISSED STEPS
  • Increased motor current
  • Enabled FarmBot “virtual trail”

@RickCarlino “Find home” and “Find length” worked as expected with v14 Beta RC 48.

1 Like