Z Axis not moving properly up

The movement retry counter resets when a movement is completed, so the number of retries only applies to a single movement in a sequence (or when using the controls).

To alleviate the issues, you can try one or more of these suggestions:

  • Decrease the minimum speed.
  • Increase the steps used for acceleration.
  • Decrease the maximum speed.
  • Only move one axis at a time.
  • Decrease the resistance that the motors have to overcome to move. This is probably not possible unless you can identify sections where the cable carrier is binding and causing an area of high resistance when moving an axis.
1 Like

Ok so then if I set max retries to something like 15 I should be fine because it resets max retry count after every successful move.

Thanks for the reply. This has helped a lot.

@Gabriel Have any clue why FB cannot issue these move commands with multiple axis without this issue? it it a communication issue between the farmbot and the server or just the sequences and arduino?

update:

So I added a lot more tension to the belts and also I increased my max and min speeds.

the current setting is maxed speed 450 x a450 y 500 z with min speed at 100 all across the board and the stop n go issue happens only when the FB is first starting the move or slowing down to the location. (it still happens at other times but the frequency is extremely random and not consistent like before.

I’m going to mess around with the acceleration speed. maybe if I increase it the FB won’t have the issue.

In general, I don’t recommend a minimum speed greater than 50. I’d still recommend decreasing your minimum speed and increasing the number of steps used for acceleration. This will help FarmBot start moving the mass of the axis more smoothly.

The issues are a combination of Arduino encoder performance, which is impacted with encoder signals sent at higher speeds and by more axes, and trouble accelerating the axes, which can be caused by excessive resistance of the hardware (wheels, cable carrier, etc.). There should be very little resistance when moving an axis by hand.

As you have experienced, lower speeds alleviate both of these issues.

I made the suggestions you posted here.

a bit smoother without a doubt and the stop n go issue happens maybe 1 a sequence.

things are looking pretty good!

Hey all,

I was able to upgrade to v1.3 this past weekend (I know, I’m hip and with it). The upgrade went very smoothly, but I’m having z-axis issues now (stopping, restarting) when the it is moving up.

I’ve reviewed the excellent information in this thread, and none of those ideas (reduce min and max speed, slower acceleration) solved the problem.

Extra troubleshooting info: if I apply a little bit of manual pressure, the movement is smooth and does not stutter/stop. The two major differences between my 1.2 and 1.3 rigs are: 1. new drivers for the stepper motors (perhaps a calibration is in order) 2. more weight on the Z-axis (vacuum pump, housing, bracket) and the motor can’t keep up.

Has anyone else had this issue after moving the vacuum pump + housing + bracket?

Hey everyone,

We are experiencing the same exact issues that are described here, specifically the issues that @Klimbim was having with the Z axis not moving upwards properly, and the issues that @Cjaramillogrows was having with the X axis not moving properly. The Z axis is also very loud when moving down, but not up, as described in this thread.

I took a video of it malfunctioning, it didn’t stop as much as it had been when moving up.
https://youtu.be/_WxRwEFrFbw

Hoping someone can help us troubleshoot this and get it working asap, we have a group of 4H students coming to see it in action next week.

Looked at your video; of course the force that it needs increases when more or less fully up (bending cables mostly). To be honest I don´t know what I did, the problem solved itself… but it is definitely related to the stepper motor being at the limit and slipping therefore… I hope FB team could answer and elaborate but most important solve this issue!!!

2 Likes

Yes, moving up is not stable. I attribute it to the additional force needed to bend cables. I also removed Z-Axis Cable Carrier Guides because I though they add friction on Cable Carrier. Yet sometimes it failed to move up especially if moving from the bottom position.

As for the sound, yes it is very noisy. I put some grease on the Z-Axis Extrusion it helped a bit.

Eugene

Yea, I also have tried various lubricants (motorcycle chain lubricant has worked the best thus far and has excellent staying power against the elements). I’ve current handicapped my max speed to 150 and the acceleration steps to 450. This seems to buy the best speed vs stuttering so far.

I’m wondering if having the vacuum pump hanging in it’s new spot is creating torque against the cross slide and the screw block, adding to the overall mechanical resistance. This may be negligible or not depending the z-axis position.

I think I will run it through a compressed break-in period to get the new UTM cable to loosen up and reduce its resistance to see if that helps.

Has anyone out there tried a different motor?

Hey guys, thanks for the suggestions! We ended up having our onsite technicians come take a look at our FarmBot and they determined that it was the 5mm to 8mm flex coupling that was giving us problems. They made us a new solid coupling that doesn’t have the spiral cut for flexibility. It still stops when going up occasionally, but it is works 95% of the time compared to previously. Here’s a picture of the new piece:

1 Like

FYI: You’ll have better luck if you move up when it is hot outside. I believe it is because moving up has to bend cables in the cable carrier. They create less stress if they are warmer.

1 Like

Thanks all, great ideas all around. I realized yesterday that the output gains for the stepper motor drivers were set to 0 gain on the new FB board. Once I boosted the gain about 25% for the z-axis, I’ve been having fewer issues.

Fuzzy