Z Axis not moving properly up

Hi all,

I noticed that since the latest update series. If I move Z up, it gets stuck at a random point during acceleration or even normal movement. Then it stops and tries again. At the end it will end up fully moved to the top, but I what I can do about it? There is no physical “friction” to be set like with the belt tension, right? Would I need to do a series with different speeds to see when it stops?

Hi Klim!

Im not sure if this will help your issue but it sounds kinda like what i was experiencing with my X axis.

Gabriel posted this as a solution on my thread:

Maybe this helps!

I am already at 600 for accel and 300 for the speed but I can try to decrease them further… but at some point it should run smoothly and hopefully not in slow motion speed…?!

Last week I wanted to fix my Z-axis because there was always a loud noise when it was moving. So I put some grease on the leadscrew to make it move more smoothly. End of story was that my Z-axis fell down immediately because it’s running more smooth than I wanted.
Maybe you could try this? :smile: (if you are able to keep motors always on …)
Can’t imagine that this is caused by any software updates :thinking:

@Ascend So you’ve tried to grease up you Z axis leadscrew? Because ours makes quite the racket and ive been curious if it would be safe enough to lube the screw up for less noise!

i know that the accel speed change has seemed to work really well for me but my issue is with the X axis, not the Z axis.It could be something different because its vertical movement comparative to horizontal which is much less effected by gravity, and weight issue but that doesn’t seem logical at this point and im pretty confident you’ve tested those variables also.

any luck yet @Klimbim?

Yea @Klimbim Im having no luck anymore with the changes - at first i thought it had helped but not really.

still getting a stop and go movement issue.

Im going to tag @Gabriel in case he has any other suggestions instead of posting on my other thread as this post is more related to our issue.

also going to try and upload a video of the issue for a better visual example.

here is a link to the video:

My current settings:

At times - it will smoothly glide along the track without a problem, other times it tries 3 times and then E-stops itself and other times it will stop -go-stop go and finish the move command. No consistency with the issue that i can replicate.

EDIT: also have tried lowering the speed which seems to help but doesn’t stop the issue

Nice video!

The main issue with those settings is the max speed. Try reducing it to 400 or less. 350 may help.

In general, you can also increase Max missed steps and Encoder missed step decay, which should help fix the issue but decrease accuracy.

Have you tried toggling Use encoders for positioning as well?

1 Like

thanks Gabriel!

I have tried reducing the max speed and unfortunately it did not help either :disappointed:

Im going to try and increase the missed steps and decay settings, maybe ill get some results from that and as for the toggling the encoder for positioning - just did that, no change yet!

I love this damn robot so much! but i cant stand not knowing what i did to get things to work lol…

it seems to be moving smoothly but im probably speaking to fast on this. All i did was change the speed down to 200 (turtle pace and it made so much noise because of the motor vibration) and then turned off use encoders for positioning and increased the speed to 450 again and no it seems to be moving smoothly? lmao - im so confused.

It may seem counter-intuitive, but a slow speed is worse because the gantry vibrates and sways giving both positive and negative encoder counts, but is much smoother at faster speeds. The worst case for the encoder (which I measured) is actually at the start and end of movements i.e. at the slowest speed, and is where you get the fastest pulses (which can be missed by the software).

If the axis is stationary and another axis moving then the small vibration causes encoder counts to be generated, both positive and negative (because it isn’t moving anywhere, just oscillating back and forth). These pulses can easily be ‘faster’ then the pulses when running at maximum speed.

1 Like

Yup - spoke to early.

The issue is happening a bit less but still consistent when im trying to execute one of my sequences.

If your encoder would miss steps, farmbot would fix the position when the movement is done, right? As far as I’ve seen, farmbot loads the encoder data when the axis movement is done. So stopping when the movement is halfway done wouldn’t be caused by encoder reasons.
Did you anyone tried changing “Start/Stop at Max”? Didn’t take a look at the code yet, maybe there is still a bug in this?

Ive got some video footage of the stop n go issue.

This is the [Video](https://drive.google.com/open?id=0B_3s7YGR1UqbRExkdjJOM0dsUkU).

It happens exactly at the same time within my sequences.

Right at the move absolute command where i have the FB move to the imported coordinates from basil plant ( x210 y 410 z-180).

other characteristics:

It doesn’t have the stop n go issue if i give it a move command from the control panel. It can run the full length of the track constantly without a single stop-n-go.

I’m testing the Y axis right now.

EDIT: Y axis seems to be working fine when moving alone but in a move command sequence, if the Z axis is moving and encounters the issue and if the Y axis is also needing to move as stated in the command the Y axis will also freeze with the z axis and then move again.

Hi @Cjaramillogrows, did you figure out where the problem lies?

1 Like

Hey @Klimbim

i did a bunch of testing and still no solution unfortunately. Id come to the conclusion that it must have something to do with the communication between between Arduino and motors when it comes to sequences.

I can still issue a move command from the control panel and FB moves along just fine.
when i execute a sequence, is the only time FB has movement issues ( stop n go)
I have noticed (but haven’t been able to replicate consistently) that if i re-do the sequence it seems to help.

I had a plant seed sequence from a while ago and noticed that when i tried executing it in a full on chain sequence it would have the same issue, so I copied the sequence and basically just deleted the first command and re-did it and then the one under it ( for good measure) and then it executed without the issue - but as I’ve developed more of my full plant seed sequence, I’ve noticed that the issue has come and gone again.
Additionally, there is also a few specific locations in my sequences that the issue is 100% constant and deleting the problem command within the sequence and then redoing it doesn’t solve the issue.

everything I’ve done for troubleshooting is VERY hit and miss. Some times i think I’ve figured out the reason why, try my solution and then get zero results. Sometimes I’m not even doing anything different just helplessly executing the command in the hopes ill notice something and then it works just fine.

Hey guys,

I just wanted to re-pin this post to the top.

Still have this issue, I was wondering if @Gabriel or @roryaronson might have any information on this.

The stop N go movements seem to have gotten worse since my last post on this topic and i am now experiencing an additional issue if i have the max retries set to say 20 - the FB eventually will record 20 max retries because of the stop and go which causes the sequence to stop but the airpump stays on but oddly enough, when the this happens, i can still give it move commands and even execute any sequence i want again.

Ive got a pretty long plant seed sequence as im executing an entire garden bed seeding sequence, is there a way i can disable the max retires so that it will just continue to run through the sequence even thou its having the stop n go issue?

i have the max retries set to 2000 ( something crazy that the farmbot wont ever reach and based on my estimations @ 40 plants in my sequence multiplied by an average of 5-10 retries per plant is an estimated 200 - 400 max retires for the entire sequence)

Ive got some extra video footage to help show exactly whats gong on here but my post above is basically whats going on. its just happening alot more. Video link

adding a link to this post for a topic just created along the same lines of this issue

A few things:

  • The max retries value is for a single movement command.
  • Can share the result of halving your min speed and max speed and doubling your acceleration?
  • If you move FarmBot by hand with the motors unpowered, do you feel resistance?
  • If you want the pump to turn off when the max number of retries is reached, you need to enable E-STOP on movement error.
  • Have you noticed any difference between a movement with all three axes and a movement with only a single axis?
  • Just to confirm something you mentioned above, if you send a command using the Move widget GO button from one location to another, then run a sequence that makes the same movement to and from those same coordinates, the behavior is different?

Thank you for the reply Gabriel,