Calib Params for cam get lost after firmware update


#1

Hi FB Team,

could you please look into this: Its the second time that I lost cam calibration params after a firmware update!

Thanks, Best
Klim


#2

@connor @Gabriel @RickCarlino can you please solve it…?


#3

Persistent Farmware and calibration data across SD card reflashes is a feature that has not yet been implemented, but is under development. Therefore, if FarmBot OS is updated by reflashing the SD card, currently those data will be lost.

However, if FarmBot OS is updated automatically or through the Web App (and has not been factory reset), it should keep Farmware and calibration data. If it loses the data, that would be a bug. We have not seen this happen so we would need more information about the issue if that is the case. The feature under development mentioned above will also solve the issue when it is released.


#4

I have seen it happen at least during the last three updates. Please look into all threads where I reported it. What information else do you need? Farmwares are deleted as well after update over the air. I did not touch the SD card, it is staying untouched in the bot since months!


#5

Hey @Gabriel @connor can you please try to solve the connection issues, this is sooo annoying!

Today i saw that the bot was last connected yesterday evening, it says:
Busy Syncing 0.6, 0.8, 0.17 Sep 1, 6:01pm

It said it was disconnected but I did not detect a farmbot network. Therefore I unplugged it and plugged it back again and voilá the bot is up again. But when I look into the farmware tab no farmware is installed?!

These connectivity problems are so heavy that the farmbot is useless to use without supervision, e.g. holidays. This is very frustrating.


#6

I’ve been working on a fix for this. Unfortunately it doesn’t happen to me on any of my bots that I have available to me, so I’m sort of just guessing as to what the problem is.

I’ve also been working on a method of collecting more information in the event of a crash/disconnect that a user will be able to upload for analysis by developers since these events usually happen when Farmbot isn’t being actively monitored.


#7

When are you able to release a fix?


#8

Well as I’ve said i’m unable to reproduce any disconnecting with the bots available to me, so I don’t have a “fix” just yet. The next release to go out will likely have the

method of collecting more information in the event of a crash/disconnect that a user will be able to upload

Built in to aid in figuring out what exactly is causing bots to go offline. Once we are able to identify the root cause of the disconnects, it shouldn’t be too long before a “fix” for that particular problem is out.

We have a release with a few little bug fixes that is almost ready to go out, but I am out of the office until next Monday at a conference.


#9

I would be more than happy to act as alpha tester if you walk me through the install procedure ;=)


#10

Sure. We post beta updates pretty frequently. It might be easy to setup a hook that posts or updates a post on the forum here so users can be notified. I’ll be sure to check back in here or make a new thread for beta updates.


#11

I figured out today that MLH farmware was deleted as well during one of the last reboots, e.g. loosing network and resetting after the amount of time even that factory reset option is off. Is that related to the bugs that you will fix in the next release?

Yes that would be great! So what would I need to do to connect to the staging server, I guess?


#12

We allow beta updates on the production server, and I believe the staging server is now limited to only Farmbot developers at the moment.

I will make a FAQ page on how to opt into beta updates and what to expect from them.


#13

Hi @connor any news? Had another two disconnects yesterday and needed to freshly setup the bot (walking through the configuration start menu…)…

It can´t be the wifi connection, as my nodeMCU is always online and sending, even with much lower RSSI…


#14

I’m still out of the office until Monday.

There are a few types of"disconnects" here.

One I know of is Your particular bot has issues with DNS resolution, not the connection itself. Something on your network is stopping Farmbot from being able to resolve the Farmbot servers IP address. This could be due to latency, wifi connection, some firewall, a bad router etc. There’s not really anything Farmbot can do about that, and no firmware update will be able to fix this, it’s something with your LAN.

The problems you experience after a disconnect are certainly fixable, but as I’ve said before, I can not reproduce the disconnects. When I get back on Monday I have an update that will at least collect better logs of what happened.


#15

I wrote up a guide here for Opting into beta updates. Please be sure to read the entire document.


#16

3 posts were merged into an existing topic: Farmbot OS Disconnects and reconnects


#17

@Gabriel and @connor:

After the last firmware update to 6.4.11 the params for calibration were lost again, as expected and still not fixed, I believe? So I again for the how many"eth" time now reentered the calib values, took a picture of the garden but it did not show up in the farm designer… any ideas?


#18

@Gabriel @connor @roryaronson

still no answer I cannot see any pictures in the farm designer at the moment… :frowning:


#19

Running Camera Calibration should get the images to show up in the Farm Designer again. Also make sure the photo you want to appear was taken at the same z-axis height as when camera calibration was run.

As mentioned previously, a feature is under development that, when released, will resolve the data persistence issue. Until then, we will continue to investigate the update issue.


#20

@Gabriel: I do have a scan image or a calibrate button inside the Camera Calibration Farmware. As far as I know, the scan image just scans the image again to detect the two red dots and the calibrate button takes a picture before. I just need to update the coefficients without physically rerunning the calibration. That is not covered at the moment? I just entered the values but they do not seem to be transferred into the system…